summaryrefslogtreecommitdiff
path: root/x11-plugins/docker/docker-1.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /x11-plugins/docker/docker-1.5-r2.ebuild
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'x11-plugins/docker/docker-1.5-r2.ebuild')
-rw-r--r--x11-plugins/docker/docker-1.5-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-plugins/docker/docker-1.5-r2.ebuild b/x11-plugins/docker/docker-1.5-r2.ebuild
new file mode 100644
index 000000000000..8999156d944e
--- /dev/null
+++ b/x11-plugins/docker/docker-1.5-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Openbox app which acts as a system tray for KDE and GNOME2"
+HOMEPAGE="https://icculus.org/openbox/2/docker/"
+SRC_URI="https://icculus.org/openbox/2/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.0.4
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${P}-makefile_rename.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+pkg_postinst() {
+ einfo "To avoid collision with app-emulation/docker, binary was renamed to wmdocker"
+}