summaryrefslogtreecommitdiff
path: root/x11-plugins/docker/docker-1.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /x11-plugins/docker/docker-1.5-r2.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'x11-plugins/docker/docker-1.5-r2.ebuild')
-rw-r--r--x11-plugins/docker/docker-1.5-r2.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/x11-plugins/docker/docker-1.5-r2.ebuild b/x11-plugins/docker/docker-1.5-r2.ebuild
index 37de7b671cf3..9f742ebe552d 100644
--- a/x11-plugins/docker/docker-1.5-r2.ebuild
+++ b/x11-plugins/docker/docker-1.5-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit toolchain-funcs
DESCRIPTION="Openbox app which acts as a system tray for KDE and GNOME2"
@@ -10,17 +11,19 @@ SRC_URI="https://icculus.org/openbox/2/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ppc ~ppc64 ~sparc x86"
-IUSE=""
+KEYWORDS="~alpha amd64 ppc ~ppc64 ~sparc x86"
RDEPEND=">=dev-libs/glib-2.0.4
x11-libs/libX11"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-PATCHES=( "${FILESDIR}/${P}-makefile_rename.patch" )
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile_rename.patch
+)
src_compile() {
+ tc-export PKG_CONFIG
emake CC="$(tc-getCC)"
}