summaryrefslogtreecommitdiff
path: root/x11-plugins/astime/astime-2.8-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/astime/astime-2.8-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/astime/astime-2.8-r2.ebuild')
-rw-r--r--x11-plugins/astime/astime-2.8-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-plugins/astime/astime-2.8-r2.ebuild b/x11-plugins/astime/astime-2.8-r2.ebuild
new file mode 100644
index 000000000000..ea8e6a19f84d
--- /dev/null
+++ b/x11-plugins/astime/astime-2.8-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Analogue clock utility for X Windows"
+HOMEPAGE="http://www.tigr.net/"
+SRC_URI="${HOMEPAGE}afterstep/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="jpeg"
+
+RDEPEND="x11-libs/libXpm
+ x11-libs/libSM
+ jpeg? ( virtual/jpeg:0 )"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+PATCHES=( "${FILESDIR}/respect-ldflags.patch" )
+
+src_configure() {
+ econf $(use_enable jpeg)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install () {
+ dobin "${PN}"
+ newman "${PN}.man" "${PN}.1"
+ einstalldocs
+}