summaryrefslogtreecommitdiff
path: root/x11-plugins/asclock/asclock-2.0.12-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /x11-plugins/asclock/asclock-2.0.12-r4.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'x11-plugins/asclock/asclock-2.0.12-r4.ebuild')
-rw-r--r--x11-plugins/asclock/asclock-2.0.12-r4.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/x11-plugins/asclock/asclock-2.0.12-r4.ebuild b/x11-plugins/asclock/asclock-2.0.12-r4.ebuild
new file mode 100644
index 000000000000..4d5b8555b83d
--- /dev/null
+++ b/x11-plugins/asclock/asclock-2.0.12-r4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo toolchain-funcs
+
+DESCRIPTION="Clock applet for AfterStep"
+HOMEPAGE="http://tigr.net/afterstep/applets/"
+SRC_URI="http://www.tigr.net/afterstep/download/asclock/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+
+DEPEND="x11-libs/libXpm"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-gcc41.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-fix-implicit-func-decl.patch
+)
+
+src_prepare() {
+ default
+
+ ln -s themes/classic default_theme || die
+}
+
+src_configure() {
+ :;
+}
+
+src_compile() {
+ local x
+
+ # Will break Solaris
+ [[ ${CHOST} == *-linux-gnu ]] && CFLAGS="${CFLAGS} \
+ -Dlinux \
+ -D_POSIX_C_SOURCE=199309L \
+ -D_POSIX_SOURCE \
+ -D_XOPEN_SOURCE"
+
+ for x in asclock parser symbols config; do
+ edo $(tc-getCC) \
+ ${CPPFLAGS} ${CFLAGS} ${ASFLAGS} \
+ -I"${EPREFIX}"/usr/include \
+ -D_BSD_SOURCE \
+ -D_SVID_SOURCE \
+ -DFUNCPROTO=15 \
+ -DNARROWPROTO \
+ -c -o ${x}.o ${x}.c
+ done
+
+ edo $(tc-getCC) \
+ ${LDFLAGS} \
+ -o asclock \
+ asclock.o parser.o symbols.o config.o \
+ -L"${ESYSROOT}/usr/$(get_libdir)" \
+ -L"${ESYSROOT}"/usr/lib/X11 \
+ -lXpm -lXext -lX11
+}
+
+src_install() {
+ dobin asclock
+ local themesdir="/usr/share/${PN}/themes"
+ insinto ${themesdir}
+ doins -r themes/*
+ dodoc README README.THEMES TODO
+ cd "${ED}"/${themesdir} || die
+ rm Freeamp/Makefile{,.*} || die
+ ln -s classic default_theme || die
+}