summaryrefslogtreecommitdiff
path: root/x11-plugins/asapm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /x11-plugins/asapm
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'x11-plugins/asapm')
-rw-r--r--x11-plugins/asapm/Manifest2
-rw-r--r--x11-plugins/asapm/asapm-3.1-r1.ebuild24
2 files changed, 17 insertions, 9 deletions
diff --git a/x11-plugins/asapm/Manifest b/x11-plugins/asapm/Manifest
index 04fa400b8a43..e2087dc23551 100644
--- a/x11-plugins/asapm/Manifest
+++ b/x11-plugins/asapm/Manifest
@@ -2,5 +2,5 @@ AUX asapm-3.1-autoconf.patch 550 BLAKE2B d8d5756a905d63c927c79055ca3279a29065862
AUX asapm-3.1-include.patch 182 BLAKE2B e20dbd9d09cb48b5a2fe7f4f74c0ad6de46bbeecb99a83509a9733b4fdbb5616eb0e8155b255e528f4af8b45ff97eab25546db676cd5bf59a34a06e4f978bde0 SHA512 31308eb25b3ed6c409b38cb298e3bc411d47e28ead61605ce490e0698bacea4d741425259f3192958204899851e339716c99270216d094dd5554a2b54bf5feef
AUX asapm-3.1-ldflags.patch 330 BLAKE2B 068181eb71add675b58766dd336618ebcd64253483d10771052fccf0726b81be6832aa60e99a1979bcdd620350ce6874a4c34551a03b50437dd727b3d9081bfb SHA512 6fbf3311c20ae647d52bcc37c741ba16d5f74d042811e0b97554979cae637fa74bc58fa9ad55ddb20399bee29efe46857bfacf90118207f97c1b3ca58935d89f
DIST asapm-3.1.tar.gz 63203 BLAKE2B 9695c21066c3855a8d945af78751e3f5d0d06950cc199c60d886a5bd8b99fb2f9eb2e2035624f161b85b81bf58acf80b8a494753d74a4e9b1163f16b4037031e SHA512 01859deccba952428671fd77ce87251b1fe0c21221af13db9b14c9ef28babad11e1582fed02b076f16d66bdab398eeb7a48b5e3cdebcb4e153978e04f022a579
-EBUILD asapm-3.1-r1.ebuild 714 BLAKE2B 7686d7abe939aea4d3d512af1e39fa6fb8031e2d81a022f7c603db7cf63fca10de688cec7857ff334480cdafe8174187ced7aeb16d45d8abe3261fcdb63a0f45 SHA512 e79fd761521c4220ecdf23fde8d58546ef4316be496c59bf0b672438468cedbe3884ab09dff8f7f4f0e717f3bed2bd4febbff5e8013fd52b0efa6949bd6a58a1
+EBUILD asapm-3.1-r1.ebuild 794 BLAKE2B 08a69cb25b2d5c46ce5227e2a14d4a376b862644ff0be6a2e9161229deb8794857280a492ebde5f1fdc482473997e04b56a6bccfba24ca1e4260027b41f48c1a SHA512 1e89619002b18297f0bc2c7c0852c9adf13c838613dc2fb6f27c49b41ae63a140eb695b95449cca3f0d4ad48059cbf2dd1d494e77d71ab11dfc66793fdc9f8e5
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/x11-plugins/asapm/asapm-3.1-r1.ebuild b/x11-plugins/asapm/asapm-3.1-r1.ebuild
index 8d6ea14a2354..538bca9b0512 100644
--- a/x11-plugins/asapm/asapm-3.1-r1.ebuild
+++ b/x11-plugins/asapm/asapm-3.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools eutils toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="APM monitor for AfterStep"
HOMEPAGE="http://tigr.net/afterstep/applets/"
@@ -12,19 +12,27 @@ SRC_URI="http://www.tigr.net/afterstep/download/asapm/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc -sparc ~x86"
-IUSE=""
RDEPEND="x11-libs/libX11
x11-libs/libXpm"
-
DEPEND="${RDEPEND}
x11-base/xorg-proto"
+PATCHES=(
+ "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-include.patch
+ "${FILESDIR}"/${P}-autoconf.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-{ldflags,include,autoconf}.patch
- cp autoconf/configure.in . || die
- AT_M4DIR=autoconf eautoconf
+ default
+
tc-export CC
+
+ cp autoconf/configure.in . || die
+ mv configure.{in,ac} || die
+
+ AT_M4DIR=autoconf eautoreconf
}
src_install() {