summaryrefslogtreecommitdiff
path: root/x11-plugins/allin1/allin1-0.5.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/allin1/allin1-0.5.0-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/allin1/allin1-0.5.0-r2.ebuild')
-rw-r--r--x11-plugins/allin1/allin1-0.5.0-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-plugins/allin1/allin1-0.5.0-r2.ebuild b/x11-plugins/allin1/allin1-0.5.0-r2.ebuild
new file mode 100644
index 000000000000..e6a0df1db748
--- /dev/null
+++ b/x11-plugins/allin1/allin1-0.5.0-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="All in one monitoring dockapp: RAM, CPU, Net, Power, df, seti"
+HOMEPAGE="http://ilpettegolo.altervista.org/linux_allin1.en.shtml"
+SRC_URI="mirror://sourceforge/allinone/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+PATCHES=( "${FILESDIR}/makefile-r2.patch" )
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin src/allin1
+ doman docs/allin1.1
+ dodoc README README.it TODO ChangeLog BUGS src/allin1.conf.example
+}