summaryrefslogtreecommitdiff
path: root/x11-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-25 19:01:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-25 19:01:08 +0000
commitfc68863e718441fe15bb0dea2ca03ea06a6f558d (patch)
tree5cfeda3e589273a4fa9d6c84119acf0db4c2453c /x11-misc
parentecf595717796995cab38a07093dc9597d55d0ea6 (diff)
gentoo auto-resync : 25:03:2024 - 19:01:08
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/Manifest.gzbin46542 -> 46548 bytes
-rw-r--r--x11-misc/compose-tables/Manifest2
-rw-r--r--x11-misc/compose-tables/compose-tables-1.8.8.ebuild46
3 files changed, 48 insertions, 0 deletions
diff --git a/x11-misc/Manifest.gz b/x11-misc/Manifest.gz
index 370e6d28dde5..216a6d34a2e4 100644
--- a/x11-misc/Manifest.gz
+++ b/x11-misc/Manifest.gz
Binary files differ
diff --git a/x11-misc/compose-tables/Manifest b/x11-misc/compose-tables/Manifest
index e3160e60dbbc..ccdeb58f594e 100644
--- a/x11-misc/compose-tables/Manifest
+++ b/x11-misc/compose-tables/Manifest
@@ -1,3 +1,5 @@
DIST libX11-1.8.7.tar.xz 1859256 BLAKE2B 335d8af91c13aba11255c266c4687a7f66b021207a92485d723b4107601bbabb6a0e5535241a3bcff4ac9a99142730d2b3d2e2eaff86b507fee5b35a2590d792 SHA512 d53bfc18f38d339a6a695b09835b2ae96b323881678bfe7ddca697605e3bdf4102ff49cc3078880a6c55b5977fcdd0aadaf5429086132de3a5bda302f79a2fa6
+DIST libX11-1.8.8.tar.xz 1872808 BLAKE2B d180932c65c565d113ae768bb0035aa98ff7dd265de9a7907f54f994b1520d7fc67699032450afc5d8f9427247f73dcf71259ff6a3f734d71f6e8b6181c6891b SHA512 4e7ce8f2d88b9475f960ea1d5730ece8953509e0c057cf2d0a2f5fa6a36e6577b0dcd7f16ac91b8fdd804aabec6d7e8f3067a3a8667bd2e41d72dd68ab70ef82
EBUILD compose-tables-1.8.7.ebuild 966 BLAKE2B 3d311500f1975ad468872ba6a7a0455cd12373136383bf6cd8cc9b79e226398217d3b6ea512a3e524594eb35f01978a6501e6ec72bbb2f22489075e4f478c53f SHA512 ccd113992763322e33b1d1fa398195edaf7d38271170053de474bc348e0b4d85858ca8ba8eafd524750515404700864c179fb7adf2b8f0e7a90495427297b005
+EBUILD compose-tables-1.8.8.ebuild 1031 BLAKE2B fa277ed390cb7854b25247c5ed95a402e9511e6e1c7575c707261e460d35e00004453d3af326a225f556a6066639f0601c6a20bc774751235d5641358219e512 SHA512 eb01330f871d2b83e346658d5cd1b587a9293bee8e0c7a216274c3465794dd214d8e81fd78f0c4af1244cf6c956ab7c95b057686b8315eb78033c145217e89ba
MISC metadata.xml 395 BLAKE2B 7912fcccfd8d8a4c9c1e5601783a0668679506638511ee719bf7bb95f99415fe95a417343060cf5ca3fe918ab1f9847f74861af36d3c712afa321272cd13cf66 SHA512 c2956ef519fe59d0f713732059224568b9d7c34579654b71993b02227a512c1ac3057dc7f81c6bc93834fd4fee212f1ae26f4055ea92f3eb7524da7d9e690f8f
diff --git a/x11-misc/compose-tables/compose-tables-1.8.8.ebuild b/x11-misc/compose-tables/compose-tables-1.8.8.ebuild
new file mode 100644
index 000000000000..ade5421accec
--- /dev/null
+++ b/x11-misc/compose-tables/compose-tables-1.8.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_MULTILIB=no
+XORG_TARBALL_SUFFIX=xz
+inherit xorg-3
+
+# Note: please bump this with x11-libs/libX11
+DESCRIPTION="X.Org Compose Key tables from libX11"
+# xorg-3.eclass would attempt to fetch a tarball with a matching name to this package
+SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/lib/libX11-${PV}.tar.${XORG_TARBALL_SUFFIX}"
+S="${WORKDIR}/libX11-${PV}/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+# Only needed by configure
+DEPEND="
+ x11-base/xorg-proto
+ >=x11-libs/libxcb-1.11.1
+ x11-libs/xtrans"
+# RDEPEND=""
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ --without-xmlto
+ --without-fop
+ --disable-specs
+ --disable-xkb
+ --with-keysymdefdir="${ESYSROOT}/usr/include/X11"
+ )
+ xorg-3_src_configure
+}
+
+src_compile() {
+ emake -C nls
+}
+
+src_test() {
+ :;
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C nls install
+}