summaryrefslogtreecommitdiff
path: root/x11-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-13 12:04:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-13 12:04:20 +0100
commitd993571e2ee444d08f4e9e90d493ee37338657e3 (patch)
tree5a49a1d4ceffe800051e363f64571c3b6735d2f7 /x11-misc
parent266d65d0cceeb55ab2cc3bf4e465d7f35502a900 (diff)
gentoo auto-resync : 13:04:2024 - 12:04:19
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/Manifest.gzbin46537 -> 46536 bytes
-rw-r--r--x11-misc/xrootconsole/Manifest1
-rw-r--r--x11-misc/xrootconsole/xrootconsole-0.6-r2.ebuild43
3 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/Manifest.gz b/x11-misc/Manifest.gz
index 2dcdaa497f3c..a144e93ee7d9 100644
--- a/x11-misc/Manifest.gz
+++ b/x11-misc/Manifest.gz
Binary files differ
diff --git a/x11-misc/xrootconsole/Manifest b/x11-misc/xrootconsole/Manifest
index 37b7ba791634..7d9c1df07f62 100644
--- a/x11-misc/xrootconsole/Manifest
+++ b/x11-misc/xrootconsole/Manifest
@@ -3,4 +3,5 @@ AUX xrootconsole-0.6.manpage.patch 1038 BLAKE2B df8fdc45f1167ce4e8dd948bba549e88
AUX xrootconsole-0.6.noversion.patch 1780 BLAKE2B 203dca249d2dd8d6ac675cd617615ba551ab3bc6e14dfede9b133840bf9779be186b423f03a1ca04b262ac31593511d34c8a82c05b06cc1f6d68ed5390fa08c1 SHA512 d75228770d31deb969e1f05f99eb0df2839564d9f9db7d5cb9efb00737e1df5632e14c0d5071ef0a5ff57054e62e1c112bd27074b60ac47220ec50f02a170c45
DIST xrootconsole-0.6.tar.gz 15951 BLAKE2B b11035742c08d7f989b131a22e64338874fa609fe09852ada76779c7d850c9cc16a86baf29785fb86edb9fa9aad2d33fd90392f50e134c74dd1ab4765776a8e8 SHA512 9e773eac96f9bb0103880cce8a3bc24211c50b369c4c389bd020c774a4f643947b634ebc5e7b266b28f75f57887d8edc72d8d582e8535c7320f56292194ed7f9
EBUILD xrootconsole-0.6-r1.ebuild 800 BLAKE2B 059ada1faf3114995b8f417402f17a4a3c73f8af7072d2fa71fd4b25f83626df6f37e80721dc45822a90737eb8e821cf5d80746e52d17c67cb377b76660d45ef SHA512 401945e5727b23e424c8aadbb123817df192f354b956973c781f1602cb448c5489d3eb6a26efe52a818d14d2a00e848a88a943879c909cbf6ca3c6a2b98cbfdc
+EBUILD xrootconsole-0.6-r2.ebuild 784 BLAKE2B 3eb3066b7da0fee29aef683856e2dc6903c5d9d26c1a382d6df7e9698d409f2f369d186826c91bd1936ccd6ff64404ae4851aa6aeeaec6a531148f1f00a5ca3d SHA512 dc7675bd7c463b4fcbaea991175a3be789121d7c1ccf9a4467da4c811167599b063e6943ed4a2c8080d687bc688e59e13f85a8735ddc325ca24173c5d159f7d0
MISC metadata.xml 359 BLAKE2B be06f7d75fb39abd07108b163729c72a70a6bf9e4cafa61b6d6896749d2fb77830229a0041e7210a674c87aa5966c7a8062174341ef38b65195bcaab0fe5fa17 SHA512 80f911d289118adbc386117bec1a104a33bec04d77d4ef0353301a38567ae8e0996bae13e1b4675b847946c8dd33a6f2dd50a7977cbeecd4636a1e447eaeb43a
diff --git a/x11-misc/xrootconsole/xrootconsole-0.6-r2.ebuild b/x11-misc/xrootconsole/xrootconsole-0.6-r2.ebuild
new file mode 100644
index 000000000000..1ed3bf5912a3
--- /dev/null
+++ b/x11-misc/xrootconsole/xrootconsole-0.6-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility that displays its input in a text box on your root window"
+HOMEPAGE="https://sourceforge.net/projects/xrootconsole/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}.noversion.patch"
+ "${FILESDIR}/${P}.makefile.patch"
+ "${FILESDIR}/${P}.manpage.patch"
+)
+
+src_compile() {
+ tc-export CC PKG_CONFIG
+ emake
+}
+
+src_install() {
+ dodir /usr/bin
+
+ emake \
+ MANDIR="${ED}/usr/share/man/man1" \
+ BINDIR="${ED}/usr/bin/" \
+ install
+
+ einstalldocs
+}