summaryrefslogtreecommitdiff
path: root/x11-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /x11-misc
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/Manifest.gzbin48602 -> 48608 bytes
-rw-r--r--x11-misc/qt5ct/Manifest2
-rw-r--r--x11-misc/qt5ct/qt5ct-1.5.ebuild49
-rw-r--r--x11-misc/shared-mime-info/Manifest2
-rw-r--r--x11-misc/shared-mime-info/shared-mime-info-2.1.ebuild2
-rw-r--r--x11-misc/xdotool/Manifest4
-rw-r--r--x11-misc/xdotool/xdotool-3.20160805.1.ebuild57
-rw-r--r--x11-misc/xdotool/xdotool-3.20210903.1.ebuild2
-rwxr-xr-x[-rw-r--r--]x11-misc/xhkeys/files/xhkeys0
-rw-r--r--x11-misc/xsel/Manifest2
-rw-r--r--x11-misc/xsel/xsel-1.2.0-r1.ebuild2
11 files changed, 57 insertions, 65 deletions
diff --git a/x11-misc/Manifest.gz b/x11-misc/Manifest.gz
index 04268b0a424a..953451062a3c 100644
--- a/x11-misc/Manifest.gz
+++ b/x11-misc/Manifest.gz
Binary files differ
diff --git a/x11-misc/qt5ct/Manifest b/x11-misc/qt5ct/Manifest
index 2c84c03d3df2..fcd175279f91 100644
--- a/x11-misc/qt5ct/Manifest
+++ b/x11-misc/qt5ct/Manifest
@@ -1,3 +1,5 @@
DIST qt5ct-1.3.tar.bz2 80506 BLAKE2B eda2d69fcddf80553358d3c9e9bd0ef33355919c5b62912d8e79a84a36ee5a25d1dab553b6413d78e16ce69435861a01b298ae97202a77f1f50ed805f14445dd SHA512 9f4397d5cfc3dec14330759f213ae99b02ae36d3ea48dfdb3015c3b7d3fe12cde619af855d7320566ca32120e8689e4b39f78e4fdf9886e2472aef570beb75bd
+DIST qt5ct-1.5.tar.bz2 81089 BLAKE2B 8bf02a6c53c68f30e0647ff7c40c9d80044cbf914ee13f9e7f13ad6424e5cf73b9460af70ea484d498bfb693e8f8b018f7e32cac6205ffa2dba05930c6d0610c SHA512 fc16c7849a89aa8ee9480162888294638bc01f83b89d86c978397e58f6da4360cf07b9f558635b8a5b13bd10d18f3ad49663fe8a76183da9ae55aac23230b1e5
EBUILD qt5ct-1.3.ebuild 983 BLAKE2B ee87fbc6d7fdec639af3ccca9d05c87780a1e45d284f1a4988eb3a13daa3189db6cc0065b181c7d1c327524b763ae4374a2779b85ac5f9e94f3c57e8bc1085a2 SHA512 503757a6945405b48a1509ae9602ff451ac1df141c863da09f987c1df61256048a026ae86897c9b93f14b27e906ddd784264692a3564e4aaefbecd5bb0c6a2b0
+EBUILD qt5ct-1.5.ebuild 985 BLAKE2B 26f376ed5fc342b214b58c203689a4c24917decee861ac899e7cce28f29c71b3a55cc29f1dd8f37e00798cd97690cbd74c75c02e35bf21464744f0ffc3179d16 SHA512 86c8419c2c401eca25eaa1069a66e2ad0485b66b3d7c992e46e296240e050afdeb91a467bd8897dbfe7917527e447f46fe2c862ce44853dcd29a1b7f5e67b926
MISC metadata.xml 567 BLAKE2B 1593756b7456b9656c81d6884112022fbf1cafedaf8acdeb41589627bb7f176c78f648a0da43c8145d79c268aded1e6f8c8ffee89f251bfc3eab65c4e054adbb SHA512 73894bc13974d9fa795b749c5ef579f450e61197320ca777a40ebed2fc9b94e657ec9bfeb1bffd33c7809715c4025a844a611758f24f5dc23f346ddfe9542e87
diff --git a/x11-misc/qt5ct/qt5ct-1.5.ebuild b/x11-misc/qt5ct/qt5ct-1.5.ebuild
new file mode 100644
index 000000000000..bcb0e53195bc
--- /dev/null
+++ b/x11-misc/qt5ct/qt5ct-1.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt5 configuration tool, similar to qtconfig for Qt4"
+HOMEPAGE="https://sourceforge.net/projects/qt5ct/"
+SRC_URI="https://download.sourceforge.net/qt5ct/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="+dbus"
+
+RDEPEND="
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ dbus? (
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5[dbus]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ dev-qt/qtpaths:5
+"
+
+src_install() {
+ cmake_src_install
+
+ newenvd - 98qt5ct <<< 'QT_QPA_PLATFORMTHEME=qt5ct'
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ ewarn "qt5ct configuration won't be applied to the currently running sessions."
+ ewarn "Please relogin."
+ fi
+ if ! has_version 'dev-qt/qtsvg:5'; then
+ elog
+ elog "For SVG icon themes, please install 'dev-qt/qtsvg:5'."
+ elog
+ fi
+}
diff --git a/x11-misc/shared-mime-info/Manifest b/x11-misc/shared-mime-info/Manifest
index 0e8d9eaa6c50..f5a778feb747 100644
--- a/x11-misc/shared-mime-info/Manifest
+++ b/x11-misc/shared-mime-info/Manifest
@@ -2,5 +2,5 @@ AUX shared-mime-info-2.0-pkgconfig_install_path.patch 623 BLAKE2B 3ee4845d1c8c7c
DIST shared-mime-info-2.0.tar.xz 5015272 BLAKE2B 8bac4790177f8b72a8c74799d7abca360ad11a922635aa1207eead78674192b300cf0096f5943a65aa3991c8403b145adb24f5e7746db7ea6ceeab64978608c3 SHA512 f4a1ea9a408ffcff325e57585dec5862405e9fd6c79e444048039f3061676501c40168cecf8935d002644a702a21f08f0f7c680ef6a65fdf188e0d892f3cc085
DIST shared-mime-info-2.1.tar.xz 5202496 BLAKE2B e8dfc7efe78feb5a38c8115a2b332f46c3dac2f89dffad0834fa7b77560b3ef528e779ab9e42822288f85d8c434fd590859db682f3f99494aa6a4387c985e912 SHA512 87e308281e83c4cf889594f7c2e8dcb4d0d0d3910124c3816fdb886ba7d6113b2581711adcb17032b47f9b8d8b7001fab58daa52b7da7c0ef87915e341d6f1b0
EBUILD shared-mime-info-2.0-r2.ebuild 1342 BLAKE2B c4cacac538e5344cf145a411f21f1a71c6b1c9b94a6e49bd698e9589a4375dd2cc2db88a53dffba02f690bb1ee4d19297d57d570c121ebb1b34667065f605191 SHA512 49f91beb5326b84b4f88ddbb4766c1f0ed9e01e3a232777c92a3f611a1d03ab2a789cb7f61e2fc8d97d880fdd92a8bbc2ca0c4e14f908c4894dd08e68272dee4
-EBUILD shared-mime-info-2.1.ebuild 1273 BLAKE2B 5046f5b56b990c48391f96c813060e8e03b2083550022a2f0991b256e36a58f17624e2915edd4969838bafacc5f8f6c8031999dd6bdba4675232f5351957f33c SHA512 3d30ac8c336509c8aaff2c7bca200f6eaf9730940493a394254b1dbda887d1d6a3fe7963408ca48c7e4029295efa176f9b41382755f5c136d1044f23b874e4ca
+EBUILD shared-mime-info-2.1.ebuild 1272 BLAKE2B 10525c17ae77bbe1d8d0913a167db5b830f43b7ea352d227eb3b9a88721f1662e3f17feedf65ec487ce19ed85b702ecd6d33daade29930ccd91eac54e5db5093 SHA512 868e6fd1dad4743ff8ef5a2d9a2fbaabb6bdd0c2c61de6f5292857f341c76be90ac19de4ba8d36c9c74d56f02971f6004213f4f106bf3718089ca4cfd52f2b54
MISC metadata.xml 229 BLAKE2B 35bd897953d3051382021de0742162ed1a166c98224fec04fc54dc467dfe5492289b1da910ae9213259b20a0bd5bbffc041624ccb3aacc23b56de2c397861d7d SHA512 7340f6b8c0a938920b7940a288c212e868ae0d8cb18b97c028e6e959f72f94e35f37a2d864bb662fc1d01b43bd7b72efdcbcc5d48e700aaf8c845eb6b9d67fed
diff --git a/x11-misc/shared-mime-info/shared-mime-info-2.1.ebuild b/x11-misc/shared-mime-info/shared-mime-info-2.1.ebuild
index 34eafa820dcc..440f28e1465b 100644
--- a/x11-misc/shared-mime-info/shared-mime-info-2.1.ebuild
+++ b/x11-misc/shared-mime-info/shared-mime-info-2.1.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://gitlab.freedesktop.org/xdg/${PN}/uploads/${HASH}/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
# requires installed xdgmime binary
RESTRICT="test"
diff --git a/x11-misc/xdotool/Manifest b/x11-misc/xdotool/Manifest
index 2384ceaa4dca..85232b0bd665 100644
--- a/x11-misc/xdotool/Manifest
+++ b/x11-misc/xdotool/Manifest
@@ -1,7 +1,5 @@
AUX xdotool-3.20210804.2-no_hardcoded_pkg-config.patch 1073 BLAKE2B 570221beabbad51f324bded0398afd68e9d3d4f30216b7a643dc9f8c76163721bd32778137fd322faffc2edafbc63d10cc036ec5311496b24410c737735f6482 SHA512 cb206c2b708835d8f3c656778edb07f08faafe3f9c1b407526e45321dc44b59981617b0c7b96865d6c1b968c855d40c0302ce888e8a1f57719b87ee9e774449e
AUX xdotool-3.20210804.2-no_ldconfig.patch 493 BLAKE2B 044f6896b2f1279795a4263107309886518698125a818522a771374f3a1f2242f00446e87eaaff3b5eead3840459fc249405d49d47e7cd6568f5c923e096fb34 SHA512 7b3d4fe4a532e81358d81ebe9fd6e212bcceb08700df37d7d4c7fc16d95177c8f39ec8ef5a986eb6a08e7c6d209efaa8426483732dcedec39617b203de2faac5
-DIST xdotool-3.20160805.1.tar.gz 105388 BLAKE2B b836bd9c408bc4f7de562a1dd1fe18142155dc486b01912462b6d1cebc5f3f4094a407556c9f50cafb4ca3a17149e6f69303706730aabdaf94abc6d4b817d351 SHA512 e27b1029ee954ea17643ed489a00a1856e5687b03772c0f10a8e50cde3c3c957b57a3ba9890005474a744a228ef4827a83770d6890479c37a1f98f4fd7b1ff6c
DIST xdotool-3.20210903.1.tar.gz 115051 BLAKE2B d1be4fc2f5c86991804b63b85c95748dc04098f85a515b3427d980dac3d355133da0408d3e91a39e5363ae6242b02d268a8b5bc014fdd5faf51e43e24fb54176 SHA512 446ba8d354031df6a21957df92220c7dcaae5bacbb8878568a57f31097db72a88701717ec8bcd35cca3f5356bfaf47eb3ed65d2159f03b0c7a7ae5550a9b1dce
-EBUILD xdotool-3.20160805.1.ebuild 1329 BLAKE2B 53992c6c31b1ee1c710b53e4a0119e47c3ffed95621ad6fe68073321ad880ee5f3d190c33825b27d8422ea096d8c1ad67eb3ad63a85861554041e5eac5d83126 SHA512 ce2fe778428e897074ed7cf69d3fe68d08492fc67224c1a8e88ed3365adefe87ce037ed732c30256dd516976a660012f62b090d2a30685cfe6eea8620cfe0e6d
-EBUILD xdotool-3.20210903.1.ebuild 1408 BLAKE2B 3b92e6250b4db542b0ff3f103b6a82d470910a628f7addbfb7ce52f25b5bdb0bca155900c8ac255946779c9a2b9667ae857d51250a0d140821a707a64dfd20b6 SHA512 46cb622492b1a3a057e2eb6e450bad26f259b377e3bd3abbac8fb6151c82ee342d7db74e7bf641821ee448adb319730ce584eaa976484b769180b240f308134b
+EBUILD xdotool-3.20210903.1.ebuild 1407 BLAKE2B 5b6599002f4e59db685c8cf4621e2ad2f0f25ab4317c6b70077c1c1e38563467baa9af93a5b3897f91c87c7ac0b6cb5055e8709384d741b7af340b73fdeb6c7e SHA512 52bc7955d5190c9ebc0b17a4aa2aab979660beda8ad0b550ef7ba5d0a29002966646fda704ec0f29b8aad46805aad4408df8c3ec91e4b19cd4c9c01555a771df
MISC metadata.xml 560 BLAKE2B 9977cd6c5efe52174f07e4ef10141b7742c904c86afb7305ee82f9f222b2cf62a5b052f171f13d69cf3a7b00bf53f759f4cd108e7b285fafec5f5995828c0888 SHA512 381d5c1933c426b1847d2f239de60c68ec4877b482e6c33b60dffa74c7ff729cd5c62f852adcdf92b830ae8081f0b4c1a498b58416022f49bbae2013ca82ee74
diff --git a/x11-misc/xdotool/xdotool-3.20160805.1.ebuild b/x11-misc/xdotool/xdotool-3.20160805.1.ebuild
deleted file mode 100644
index b4c2443540b8..000000000000
--- a/x11-misc/xdotool/xdotool-3.20160805.1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs flag-o-matic multilib
-
-DESCRIPTION="Simulate keyboard input and mouse activity, move and resize windows"
-HOMEPAGE="https://www.semicomplete.com/projects/xdotool/"
-SRC_URI="https://github.com/jordansissel/xdotool/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
-IUSE="examples"
-
-RDEPEND="
- x11-libs/libXtst
- x11-libs/libX11
- x11-libs/libXinerama
- x11-libs/libxkbcommon
-"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
- x11-base/xorg-proto
-"
-
-# The test wants to manualy start Xvfb, wont use VirtualX and it tries
-# to run a full gnome-session. For such a tiny application i consider
-# it overkill to rewrite the test scripts to not use it's own X server
-# and add a full blown gnome just to run the tests.
-RESTRICT="test"
-
-src_prepare() {
- default
-
- sed -i \
- -e "s/installheader post-install$/installheader/" \
- -e 's:\<pkg-config\>:$(PKG_CONFIG):' \
- Makefile || die
-}
-
-src_compile() {
- tc-export CC LD PKG_CONFIG
-
- emake PREFIX="${EPREFIX}/usr"
-}
-
-src_install() {
- emake PREFIX="${ED}usr" INSTALLMAN="${ED}usr/share/man" INSTALLLIB="${ED}usr/$(get_libdir)" install
-
- dodoc CHANGELIST README
- if use examples; then
- dodoc -r examples
- fi
-}
diff --git a/x11-misc/xdotool/xdotool-3.20210903.1.ebuild b/x11-misc/xdotool/xdotool-3.20210903.1.ebuild
index 633b1908a40f..74cc0440567f 100644
--- a/x11-misc/xdotool/xdotool-3.20210903.1.ebuild
+++ b/x11-misc/xdotool/xdotool-3.20210903.1.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/jordansissel/xdotool/releases/download/v${PV}/${P}.t
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ppc ppc64 x86"
+KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
IUSE="examples"
# Many the tests want to manually start Xvfb regardless of whether there
diff --git a/x11-misc/xhkeys/files/xhkeys b/x11-misc/xhkeys/files/xhkeys
index 91d0b804f3a7..91d0b804f3a7 100644..100755
--- a/x11-misc/xhkeys/files/xhkeys
+++ b/x11-misc/xhkeys/files/xhkeys
diff --git a/x11-misc/xsel/Manifest b/x11-misc/xsel/Manifest
index c9e0ba60e170..17a06f1bce6a 100644
--- a/x11-misc/xsel/Manifest
+++ b/x11-misc/xsel/Manifest
@@ -1,4 +1,4 @@
DIST xsel-1.2.0.tar.gz 169155 BLAKE2B 59b5c2f03058be1a584f12bd5c129a008ae581545b7aed3a54240f6a0b9c29e857c7425cbf6fa6421ccd577a1907a9a6c1d7213e4ccc43309a5e8933e707847d SHA512 e28623e6cc180f2e2210c20697d21d336633f0a5272ca9b62150a1c535e8de89731acc07230a9977e391e37d3943a9d687f1f967765a15bca5092a6c6d8c4d8f
-EBUILD xsel-1.2.0-r1.ebuild 632 BLAKE2B 1cd51c2fb7f5f877d19de85669303f014f14f5cc2fd3ef7e867c2b82458c0e972fd4dd879d59025abef7b98c5f546ccb162c9797336eb80e0653df3d8093a1eb SHA512 8214ce6317c19b6d204b2ea54761598e6775cfce91e5da1bb2d78539e352524eb30e91e84e1f501fc9c22aabb0be5b6786c79cc2669a2bbe466a9d3850f36977
+EBUILD xsel-1.2.0-r1.ebuild 631 BLAKE2B a7ef2f4ee3c03981d05e7135fd79a98f1b8b094b1823d80bf47684ea741612d450074d5ad91f5dc7fa8048c74977c6733659aebf13c9bcbe88a3cd0975b05f7a SHA512 4c148ae64b474f96dfeeacf15bcf7a91ef51f50c3245c6378e64a8b57d41619029db3169d08d119187a5f8cc9deafa06ee2e5f6be1648838494a8ec40bba8abd
EBUILD xsel-9999.ebuild 568 BLAKE2B 66dcdd575ed15292aab0e6f629bfe0f65d8e83fa80e2678061a502704c3da015f55fb4553573a23782afae1945afc11264eb74b58f81ad91fe725aa542d6f56a SHA512 02903c21b332e05b486718e831fc68a51b92365b0d5021b626a8814696428e6ebfe7037be6c397909c25b4d153259de4907374d433285ac0c1c2fcc26539166d
MISC metadata.xml 277 BLAKE2B ebaa8353413cfc5519fce99f8627c71cf765fc6d42b42651e232274de315487c156d45dcb23a401dffb8f112600b0dadd56f93d2283ff86b4293dc5490ad4059 SHA512 c8ef9069153b124118a6be64375c6954ccc6f518a13805e4ff1c33c9cec136170132a580c4a9781930b709c93678c94d6448291625de34d18fea41bfd17f685d
diff --git a/x11-misc/xsel/xsel-1.2.0-r1.ebuild b/x11-misc/xsel/xsel-1.2.0-r1.ebuild
index cfe59be6b5ef..b332e0983c87 100644
--- a/x11-misc/xsel/xsel-1.2.0-r1.ebuild
+++ b/x11-misc/xsel/xsel-1.2.0-r1.ebuild
@@ -9,7 +9,7 @@ SRC_URI="http://www.vergenet.net/~conrad/software/${PN}/download/${P}.tar.gz"
LICENSE="HPND"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~mips ppc ~ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+KEYWORDS="amd64 arm ~arm64 ~hppa ~mips ppc ~ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
IUSE=""
RDEPEND="x11-libs/libX11