summaryrefslogtreecommitdiff
path: root/x11-misc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-03 23:49:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-03 23:49:50 +0100
commitc410d7a91a496a4fbbca686c80f7446305222d55 (patch)
tree8ba974498cd1061dd4e883a34bd5e9be93a95214 /x11-misc
parentc99c2410831577bef101e22948e954f85f56cba1 (diff)
gentoo auto-resync : 03:10:2023 - 23:49:49
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/Manifest.gzbin47017 -> 47015 bytes
-rw-r--r--x11-misc/compose-tables/Manifest2
-rw-r--r--x11-misc/compose-tables/compose-tables-1.8.7.ebuild43
3 files changed, 45 insertions, 0 deletions
diff --git a/x11-misc/Manifest.gz b/x11-misc/Manifest.gz
index 1d7a1ff749c7..c70ed2f3aede 100644
--- a/x11-misc/Manifest.gz
+++ b/x11-misc/Manifest.gz
Binary files differ
diff --git a/x11-misc/compose-tables/Manifest b/x11-misc/compose-tables/Manifest
index 94d55f9fb8fe..126f7f55f714 100644
--- a/x11-misc/compose-tables/Manifest
+++ b/x11-misc/compose-tables/Manifest
@@ -1,3 +1,5 @@
DIST libX11-1.8.6.tar.xz 1859460 BLAKE2B 81af515e70e013e14c07f4ead34d130477b10e93f3b057cacac77991f9db488f9821b5473a28d141ffb8ddd4a4a77303bef1a748820ccfdebd7935b528223471 SHA512 b94a578003078a42cea43d80fae2c54a3aaa30f706088bb3546331e9abfc180131cafb37887117abcc5b6116992e299974981eef96ecfcf883cc8a1aba4d1ade
+DIST libX11-1.8.7.tar.xz 1859256 BLAKE2B 335d8af91c13aba11255c266c4687a7f66b021207a92485d723b4107601bbabb6a0e5535241a3bcff4ac9a99142730d2b3d2e2eaff86b507fee5b35a2590d792 SHA512 d53bfc18f38d339a6a695b09835b2ae96b323881678bfe7ddca697605e3bdf4102ff49cc3078880a6c55b5977fcdd0aadaf5429086132de3a5bda302f79a2fa6
EBUILD compose-tables-1.8.6.ebuild 966 BLAKE2B 3d311500f1975ad468872ba6a7a0455cd12373136383bf6cd8cc9b79e226398217d3b6ea512a3e524594eb35f01978a6501e6ec72bbb2f22489075e4f478c53f SHA512 ccd113992763322e33b1d1fa398195edaf7d38271170053de474bc348e0b4d85858ca8ba8eafd524750515404700864c179fb7adf2b8f0e7a90495427297b005
+EBUILD compose-tables-1.8.7.ebuild 974 BLAKE2B 74281676596e04ff3c8696d915cb7707e25912ec6813ef814e9e7daeaaebf04e768887648938623bacc1e70cdb2d570a827bed63d07ffccf24bbbaebc25190c8 SHA512 fedef15036db889166c5efe40ad4e2184611bb014f955695a28b1a7774ed11ad1d5aa561ad0fda8e4b20cd29373ce7d8a64126a5e0e3942370c514e19cb6ecdd
MISC metadata.xml 395 BLAKE2B 7912fcccfd8d8a4c9c1e5601783a0668679506638511ee719bf7bb95f99415fe95a417343060cf5ca3fe918ab1f9847f74861af36d3c712afa321272cd13cf66 SHA512 c2956ef519fe59d0f713732059224568b9d7c34579654b71993b02227a512c1ac3057dc7f81c6bc93834fd4fee212f1ae26f4055ea92f3eb7524da7d9e690f8f
diff --git a/x11-misc/compose-tables/compose-tables-1.8.7.ebuild b/x11-misc/compose-tables/compose-tables-1.8.7.ebuild
new file mode 100644
index 000000000000..07d749e49aed
--- /dev/null
+++ b/x11-misc/compose-tables/compose-tables-1.8.7.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_MULTILIB=no
+XORG_TARBALL_SUFFIX=xz
+inherit xorg-3
+
+# Note: please bump this with x11-libs/libX11
+DESCRIPTION="X.Org Compose Key tables from libX11"
+# xorg-3.eclass would attempt to fetch a tarball with a matching name to this package
+SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/lib/libX11-${PV}.tar.${XORG_TARBALL_SUFFIX}"
+S="${WORKDIR}/libX11-${PV}/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+# Only needed by configure
+DEPEND="
+ x11-base/xorg-proto
+ >=x11-libs/libxcb-1.11.1
+ x11-libs/xtrans"
+RDEPEND=""
+
+XORG_CONFIGURE_OPTIONS=(
+ --without-xmlto
+ --without-fop
+ --disable-specs
+ --disable-xkb
+ --with-keysymdefdir="${ESYSROOT}/usr/include/X11"
+)
+
+src_compile() {
+ emake -C nls
+}
+
+src_test() {
+ :;
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C nls install
+}