summaryrefslogtreecommitdiff
path: root/x11-misc/zim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /x11-misc/zim
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'x11-misc/zim')
-rw-r--r--x11-misc/zim/Manifest1
-rw-r--r--x11-misc/zim/zim-0.72.1-r2.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/x11-misc/zim/Manifest b/x11-misc/zim/Manifest
index aded634839d7..fa58b60757b9 100644
--- a/x11-misc/zim/Manifest
+++ b/x11-misc/zim/Manifest
@@ -5,4 +5,5 @@ DIST zim-0.72.1.tar.gz 2596910 BLAKE2B cdc6c875ed316dcd5655d75c280b46189d9b70689
EBUILD zim-0.71.1-r1.ebuild 1951 BLAKE2B 252170b5d9f586212befa366909af94a1ce9e5eb78536bd9dc952f4c539c5e32e0eed71e96deb276c877dfcaff698f91993dd715e08c4b07c54dd79cd7053c30 SHA512 9525cb0a84df79ea7330ade619d242bb315184a893cb570965014fff8bc2f1c9face8f790b989859ef2c203b5cf1369b4c55a1b3b6bffcea3f0ad9bab9c71577
EBUILD zim-0.72.0.ebuild 1934 BLAKE2B 55516ba1fe0208901156c6beab8bc6a36ed3bfc60bcd1891ea129ab33d213effa7c6d3d12c9de3a588d7ca2f939d2800729577178283340d9816322bae244b84 SHA512 842f5ef971f44df01dd775c7ec65b13766b615caa6bdc862ddbf878c1022356e1749220d2c6437bc80ba234904535d00893094e76768ea92525d47c4dbb1d052
EBUILD zim-0.72.1-r1.ebuild 1934 BLAKE2B 55516ba1fe0208901156c6beab8bc6a36ed3bfc60bcd1891ea129ab33d213effa7c6d3d12c9de3a588d7ca2f939d2800729577178283340d9816322bae244b84 SHA512 842f5ef971f44df01dd775c7ec65b13766b615caa6bdc862ddbf878c1022356e1749220d2c6437bc80ba234904535d00893094e76768ea92525d47c4dbb1d052
+EBUILD zim-0.72.1-r2.ebuild 1940 BLAKE2B dfa3171f6443e914b989010e49b505895b1ea0aa06501942c5abf3c041cd501e6e2f9ba4e5b8ee6c809ae6d6984ae0ccc117b2ad972c5827ac308a553e8f08df SHA512 e9f686901a40ccf79e72a38cd4d2da0654e928c8369f36743c3880dcbe149d36d1c043dca6da5d5b0a3161a8bedb41cde177a68ac3ff879a25dfa7572d6800c6
MISC metadata.xml 824 BLAKE2B a6ac745b62015073844af9a8aae0ef1d6ca6b7c28e881c7b85d31e00c808076fa944feec5980cdefc72b5ddfa2cecb98fc96b4745df12743212a4d572679408d SHA512 26a4774e75f0a06bfedc2c26f4ca688f9a2644935302e0674ba5a5308af88bc90f291a01f5b10bba62ac0f0a46561d63bfd9289de67bc53c4be454542ea76816
diff --git a/x11-misc/zim/zim-0.72.1-r2.ebuild b/x11-misc/zim/zim-0.72.1-r2.ebuild
new file mode 100644
index 000000000000..51a1c261843f
--- /dev/null
+++ b/x11-misc/zim/zim-0.72.1-r2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_SINGLE_IMPL=1
+inherit xdg-utils distutils-r1 virtualx
+
+DESCRIPTION="A desktop wiki"
+HOMEPAGE="
+ https://zim-wiki.org/
+ https://github.com/zim-desktop-wiki/zim-desktop-wiki
+"
+SRC_URI="https://github.com/${PN}-desktop-wiki/${PN}-desktop-wiki/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyxdg[${PYTHON_MULTI_USEDEP}]
+ ')
+ x11-libs/gtk+:3[introspection]
+ x11-misc/xdg-utils
+"
+DEPEND="
+ ${RDEPEND}
+"
+DOCS=( CHANGELOG.md CONTRIBUTING.md PLUGIN_WRITING.md README.md )
+PATCHES=( "${FILESDIR}"/${PN}-0.60-remove-ubuntu-theme.patch )
+S=${WORKDIR}/${PN}-desktop-wiki-${PV/_/-}
+
+python_prepare_all() {
+ sed -i -e "s/'USER'/'LOGNAME'/g" zim/__init__.py zim/fs.py || die
+
+ if [[ ${LINGUAS} ]]; then
+ local lingua
+ for lingua in translations/*.po; do
+ lingua=${lingua/.po}
+ lingua=${lingua/translations\/}
+ has ${lingua} ${LINGUAS} || \
+ { rm translations/${lingua}.po || die; }
+ done
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+ if ! has_version ${CATEGORY}/${PN}; then
+ elog "Please install these packages for additional functionality"
+ elog " dev-lang/R"
+ elog " dev-python/gtkspell-python"
+ elog " dev-vcs/bzr"
+ elog " media-gfx/graphviz"
+ elog " media-gfx/imagemagick"
+ elog " media-gfx/scrot"
+ elog " media-sound/lilypond"
+ elog " sci-visualization/gnuplot"
+ elog " virtual/latex-base app-text/dvipng"
+ fi
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}