summaryrefslogtreecommitdiff
path: root/x11-misc/xvkbd/xvkbd-3.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/xvkbd/xvkbd-3.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/xvkbd/xvkbd-3.7.ebuild')
-rw-r--r--x11-misc/xvkbd/xvkbd-3.7.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/x11-misc/xvkbd/xvkbd-3.7.ebuild b/x11-misc/xvkbd/xvkbd-3.7.ebuild
new file mode 100644
index 000000000000..d171ff235802
--- /dev/null
+++ b/x11-misc/xvkbd/xvkbd-3.7.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="virtual keyboard for X window system"
+HOMEPAGE="http://homepage3.nifty.com/tsato/xvkbd/"
+SRC_URI="http://homepage3.nifty.com/tsato/xvkbd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXaw3d
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXtst
+"
+DEPEND="
+ ${RDEPEND}
+ app-text/rman
+ x11-misc/gccmakedep
+ x11-misc/imake
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.6-last_altgr_mask.patch
+
+ epatch_user
+}
+
+src_configure() {
+ xmkmf -a || die
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) LD=$(tc-getCC) \
+ XAPPLOADDIR="/usr/share/X11/app-defaults" \
+ LOCAL_LDFLAGS="${LDFLAGS}" \
+ CDEBUGFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake \
+ XAPPLOADDIR="/usr/share/X11/app-defaults" \
+ DESTDIR="${D}" \
+ install
+
+ rm -r "${D}"/usr/$(get_libdir) "${D}"/etc || die
+
+ dodoc README
+ newman ${PN}.man ${PN}.1
+}