summaryrefslogtreecommitdiff
path: root/x11-misc/xtoolwait/xtoolwait-1.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/xtoolwait/xtoolwait-1.3-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/xtoolwait/xtoolwait-1.3-r2.ebuild')
-rw-r--r--x11-misc/xtoolwait/xtoolwait-1.3-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-misc/xtoolwait/xtoolwait-1.3-r2.ebuild b/x11-misc/xtoolwait/xtoolwait-1.3-r2.ebuild
new file mode 100644
index 000000000000..574b3c3e28b9
--- /dev/null
+++ b/x11-misc/xtoolwait/xtoolwait-1.3-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="Xtoolwait notably decreases the startup time of an X session"
+HOMEPAGE="http://ftp.x.org/contrib/utilities/xtoolwait-1.3.README"
+SRC_URI="http://ftp.x.org/contrib/utilities/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ app-text/rman
+ x11-misc/imake
+ x11-proto/xproto"
+
+src_prepare() {
+ xmkmf || die
+ sed -i \
+ -e '/CC = /d' -e '/EXTRA_LDOPTIONS = /d' \
+ Makefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CCOPTIONS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ emake \
+ BINDIR=/usr/bin \
+ MANPATH=/usr/share/man \
+ DOCDIR=/usr/share/doc/${PF} \
+ DESTDIR="${D}" \
+ install{,.man}
+
+ dodoc CHANGES README
+}