summaryrefslogtreecommitdiff
path: root/x11-misc/xsettingsd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /x11-misc/xsettingsd
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'x11-misc/xsettingsd')
-rw-r--r--x11-misc/xsettingsd/Manifest5
-rw-r--r--x11-misc/xsettingsd/files/xsettingsd-1.0.0-add-cmake-buildsystem.patch51
-rw-r--r--x11-misc/xsettingsd/files/xsettingsd-1.0.0-return-1.patch26
-rw-r--r--x11-misc/xsettingsd/metadata.xml11
-rw-r--r--x11-misc/xsettingsd/xsettingsd-1.0.0.ebuild22
5 files changed, 115 insertions, 0 deletions
diff --git a/x11-misc/xsettingsd/Manifest b/x11-misc/xsettingsd/Manifest
new file mode 100644
index 000000000000..708671c03695
--- /dev/null
+++ b/x11-misc/xsettingsd/Manifest
@@ -0,0 +1,5 @@
+AUX xsettingsd-1.0.0-add-cmake-buildsystem.patch 1418 BLAKE2B 981c9b2160a9bce572d7b703e08db93d9619767e39368e5f5eeb41126a78223fed840b41f5804b1a20e76bce695028f101ca5fc28297a02f93e55fd99c225349 SHA512 a3ff870af999745f873d1ab8f2eadfff73b82048a401f6ceacf79f1d7c9834c84081f09e3021af3fb977d80042e663ff40278cef0f72307f877608ba6617f041
+AUX xsettingsd-1.0.0-return-1.patch 829 BLAKE2B 9e6024303ffa9f7977187e6f718f03f993788abb5421989e31fcd55f366810903eb9c375c5281803d22ec23b61286ff799bb4096840e55ebd5fc29e0ad592e15 SHA512 f66b5c0fa5068ab5e0232d5de025a59fe8a1bcbbf9b6cc398610773d32c05eb05ef40a8dc7432f5baf153c06671f24f36f07868acd119471665b7c0450ddf6a3
+DIST xsettingsd-1.0.0.tar.gz 23627 BLAKE2B e9f7dcb9fd017f34ed88f29e1954e0824764db66eac5fbcfa55e7edef51c4bdec1cb9383efe0b6cb18b88c04818b106b9c4f95fb25daaf09a76b4b4ef4e0b75f SHA512 39077050a2fc3206c308ba399328719303884dd668b61f7756f0a3a4388ed25a3cda0849a713126c22c6b80466ab74c1317fdd9cb3e652169c80c54ba0a45790
+EBUILD xsettingsd-1.0.0.ebuild 546 BLAKE2B a06b77303490e65222fcbc3196c9b6b960454ee55b65a6ead3d3ba0395055bbb50d6d3076f3b61267fbcbb59d8ba4e3be022da7c796e7fa6d5879ed619e410c3 SHA512 357174ad25dd79f04b2925e0a8d58f1ca7fc4618c53d4d9986adc5dbedd6d3456c5afc4e15bda75746bc4b68a398c3fa0debb970ca26363145cfec85195005d4
+MISC metadata.xml 330 BLAKE2B 0b8f27cf4be7ed52be5e6656a64497815cbac57febe612b3755ca2cfa9ce97f34d5807318ac39bc184b7e61b3086cecfa4e5b2e19066adfb32caead8e8833a89 SHA512 834c1c90c8297497e13de12121a39f113807228ede6ec87ad774096e870840f1f1ddc73301c63375f2600b035be12f88c77c978a8fec2e089b0624df16444959
diff --git a/x11-misc/xsettingsd/files/xsettingsd-1.0.0-add-cmake-buildsystem.patch b/x11-misc/xsettingsd/files/xsettingsd-1.0.0-add-cmake-buildsystem.patch
new file mode 100644
index 000000000000..bb46f5e37b93
--- /dev/null
+++ b/x11-misc/xsettingsd/files/xsettingsd-1.0.0-add-cmake-buildsystem.patch
@@ -0,0 +1,51 @@
+From 7ddb3b8dec442fd1bd502dc7b97841bb07526cae Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 26 Jul 2020 16:47:22 +0200
+Subject: [PATCH] Add cmake buildsystem
+
+---
+ CMakeLists.txt | 32 ++++++++++++++++++++++++++++++++
+ 1 file changed, 32 insertions(+)
+ create mode 100644 CMakeLists.txt
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+new file mode 100644
+index 0000000..42dca7d
+--- /dev/null
++++ b/CMakeLists.txt
+@@ -0,0 +1,32 @@
++cmake_minimum_required(VERSION 3.15)
++
++project(xsettingsd VERSION 1.0.0)
++
++include(GNUInstallDirs)
++
++find_package(X11 REQUIRED)
++
++set(libxsettingsd_SRCS
++ common.cc
++ config_parser.cc
++ data_reader.cc
++ data_writer.cc
++ setting.cc
++ settings_manager.cc
++)
++
++add_library(libxsettingsd STATIC ${libxsettingsd_SRCS})
++
++add_executable(xsettingsd xsettingsd.cc)
++add_executable(dump_xsettings dump_xsettings.cc)
++
++target_include_directories(xsettingsd PUBLIC "${PROJECT_BINARY_DIR}")
++target_include_directories(dump_xsettings PUBLIC "${PROJECT_BINARY_DIR}")
++
++target_link_libraries(xsettingsd PUBLIC libxsettingsd X11::X11)
++target_link_libraries(dump_xsettings PUBLIC libxsettingsd X11::X11)
++
++install(TARGETS xsettingsd DESTINATION ${CMAKE_INSTALL_BINDIR})
++install(TARGETS dump_xsettings DESTINATION ${CMAKE_INSTALL_BINDIR})
++
++install(FILES xsettingsd.1 dump_xsettings.1 DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)
+--
+2.27.0
+
diff --git a/x11-misc/xsettingsd/files/xsettingsd-1.0.0-return-1.patch b/x11-misc/xsettingsd/files/xsettingsd-1.0.0-return-1.patch
new file mode 100644
index 000000000000..795e82ce002f
--- /dev/null
+++ b/x11-misc/xsettingsd/files/xsettingsd-1.0.0-return-1.patch
@@ -0,0 +1,26 @@
+From 3ec9deebd8e3496feacab83e41846dc4fffc3404 Mon Sep 17 00:00:00 2001
+From: Phil Miller <unmobile+gh@gmail.com>
+Date: Mon, 25 Jun 2018 10:58:59 -0500
+Subject: [PATCH] Return 1 to indicate error from main()
+
+The statement 'return false;' was most likely to end up indicating successful exit
+by returning a 0 value, when failure seems to be intended.
+
+This was flagged as a warning in the Debian Clang Archive Rebuild.
+---
+ dump_xsettings.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/dump_xsettings.cc b/dump_xsettings.cc
+index f94a0c0..e9330b4 100644
+--- a/dump_xsettings.cc
++++ b/dump_xsettings.cc
+@@ -270,7 +270,7 @@ int main(int argc, char** argv) {
+
+ xsettingsd::DataReader reader(buffer, data_size);
+ if (!xsettingsd::DumpSettings(&reader))
+- return false;
++ return 1;
+
+ return 0;
+ }
diff --git a/x11-misc/xsettingsd/metadata.xml b/x11-misc/xsettingsd/metadata.xml
new file mode 100644
index 000000000000..c782cfbaf57c
--- /dev/null
+++ b/x11-misc/xsettingsd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">derat/xsettingsd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/xsettingsd/xsettingsd-1.0.0.ebuild b/x11-misc/xsettingsd/xsettingsd-1.0.0.ebuild
new file mode 100644
index 000000000000..4d15a99dad4b
--- /dev/null
+++ b/x11-misc/xsettingsd/xsettingsd-1.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Provides settings to X11 applications via the XSETTINGS specification"
+HOMEPAGE="https://github.com/derat/xsettingsd"
+SRC_URI="https://github.com/derat/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-return-1.patch
+ "${FILESDIR}"/${P}-add-cmake-buildsystem.patch
+)