summaryrefslogtreecommitdiff
path: root/x11-misc/xsetleds/xsetleds-0.1.3-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-18 05:18:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-18 05:18:37 +0100
commit95a97c3f0b0d048aaf9e183702a1d06b30415b35 (patch)
tree7f438978df863816967d0e1d3d8ee7ab5e3f12ce /x11-misc/xsetleds/xsetleds-0.1.3-r3.ebuild
parenta0d1bdbd841fa761e38f468e1009cd058af305fd (diff)
gentoo auto-resync : 18:09:2022 - 05:18:37
Diffstat (limited to 'x11-misc/xsetleds/xsetleds-0.1.3-r3.ebuild')
-rw-r--r--x11-misc/xsetleds/xsetleds-0.1.3-r3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/xsetleds/xsetleds-0.1.3-r3.ebuild b/x11-misc/xsetleds/xsetleds-0.1.3-r3.ebuild
new file mode 100644
index 000000000000..5a8da903b1c3
--- /dev/null
+++ b/x11-misc/xsetleds/xsetleds-0.1.3-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Small tool to report and change the keyboard LED states of an X display"
+HOMEPAGE="https://github.com/bmeurer/xsetleds"
+SRC_URI="
+ ftp://ftp.unix-ag.org/user/bmeurer/xsetleds/src/${P}.tar.gz
+ https://dev.gentoo.org/~jsmolic/distfiles/${P}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~hppa ~ia64 ~mips ppc sparc x86"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXtst
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-assignment.patch
+ "${FILESDIR}"/${P}-isalpha.patch
+ "${FILESDIR}"/${P}-configure-implicit-function-decl.patch
+)
+
+src_configure() {
+ tc-export CC
+
+ default
+}