summaryrefslogtreecommitdiff
path: root/x11-misc/xsensors/xsensors-0.80.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /x11-misc/xsensors/xsensors-0.80.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'x11-misc/xsensors/xsensors-0.80.ebuild')
-rw-r--r--x11-misc/xsensors/xsensors-0.80.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-misc/xsensors/xsensors-0.80.ebuild b/x11-misc/xsensors/xsensors-0.80.ebuild
new file mode 100644
index 000000000000..43258aef8b99
--- /dev/null
+++ b/x11-misc/xsensors/xsensors-0.80.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A hardware health information viewer, interface to lm-sensors"
+HOMEPAGE="https://github.com/Mystro256/xsensors/"
+SRC_URI="https://github.com/Mystro256/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ >=sys-apps/lm-sensors-3
+ dev-libs/glib:2
+ x11-libs/gtk+:3
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-gtk220.patch
+ "${FILESDIR}"/${P}-Werror.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --without-gtk2
+}
+
+src_install() {
+ default
+
+ rm -r "${ED}"/usr/share/appdata || die
+}