summaryrefslogtreecommitdiff
path: root/x11-misc/xsel/xsel-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/xsel/xsel-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/xsel/xsel-9999.ebuild')
-rw-r--r--x11-misc/xsel/xsel-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-misc/xsel/xsel-9999.ebuild b/x11-misc/xsel/xsel-9999.ebuild
new file mode 100644
index 000000000000..b2971adb4fed
--- /dev/null
+++ b/x11-misc/xsel/xsel-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools git-r3
+
+DESCRIPTION="Command-line program for getting and setting the contents of the X selection"
+HOMEPAGE="http://www.vergenet.net/~conrad/software/xsel"
+EGIT_REPO_URI="https://github.com/kfish/xsel.git"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+"
+DEPEND="
+ ${RDEPEND}
+ x11-proto/xproto
+ x11-libs/libXt
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}