summaryrefslogtreecommitdiff
path: root/x11-misc/xsel/xsel-1.2.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-16 17:51:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-16 17:51:01 +0100
commitd83532aee7e94505bf23da29e6224ca164aac759 (patch)
treefcd6dbea91816dd541b6c602b5fed02ca574a5f6 /x11-misc/xsel/xsel-1.2.0-r2.ebuild
parenta2844b413d00a2859401e017a0311986151e1594 (diff)
gentoo auto-resync : 16:04:2023 - 17:51:01
Diffstat (limited to 'x11-misc/xsel/xsel-1.2.0-r2.ebuild')
-rw-r--r--x11-misc/xsel/xsel-1.2.0-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-misc/xsel/xsel-1.2.0-r2.ebuild b/x11-misc/xsel/xsel-1.2.0-r2.ebuild
new file mode 100644
index 000000000000..fa1470e14cf4
--- /dev/null
+++ b/x11-misc/xsel/xsel-1.2.0-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Command-line program for getting and setting the contents of the X selection"
+HOMEPAGE="http://www.vergenet.net/~conrad/software/xsel"
+SRC_URI="http://www.vergenet.net/~conrad/software/${PN}/download/${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/libXt"
+
+PATCHES=( "${FILESDIR}"/${P}-Werror.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}