summaryrefslogtreecommitdiff
path: root/x11-misc/xrestop/xrestop-0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/xrestop/xrestop-0.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/xrestop/xrestop-0.4.ebuild')
-rw-r--r--x11-misc/xrestop/xrestop-0.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-misc/xrestop/xrestop-0.4.ebuild b/x11-misc/xrestop/xrestop-0.4.ebuild
new file mode 100644
index 000000000000..be03d09d0d16
--- /dev/null
+++ b/x11-misc/xrestop/xrestop-0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="'Top' like statistics of X11 client's server side resource usage"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/xrestop"
+SRC_URI="http://projects.o-hand.com/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc sparc x86 ~x86-fbsd"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXres
+ x11-libs/libXt
+"
+DEPEND="
+ ${RDEPEND}
+ x11-proto/xproto
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ eautoreconf
+}
+
+DOCS=( AUTHORS ChangeLog NEWS README )