summaryrefslogtreecommitdiff
path: root/x11-misc/xpad/xpad-5.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /x11-misc/xpad/xpad-5.7.0.ebuild
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'x11-misc/xpad/xpad-5.7.0.ebuild')
-rw-r--r--x11-misc/xpad/xpad-5.7.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/xpad/xpad-5.7.0.ebuild b/x11-misc/xpad/xpad-5.7.0.ebuild
new file mode 100644
index 000000000000..f445ca27ceed
--- /dev/null
+++ b/x11-misc/xpad/xpad-5.7.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A sticky note application for GTK"
+HOMEPAGE="https://launchpad.net/xpad"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk
+ dev-libs/atk
+ >=dev-libs/glib-2.58:2
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3[X]
+ x11-libs/gtksourceview:4
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-util/intltool-0.31
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}