summaryrefslogtreecommitdiff
path: root/x11-misc/xpad/xpad-4.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/xpad/xpad-4.9.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/xpad/xpad-4.9.0.ebuild')
-rw-r--r--x11-misc/xpad/xpad-4.9.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/xpad/xpad-4.9.0.ebuild b/x11-misc/xpad/xpad-4.9.0.ebuild
new file mode 100644
index 000000000000..6cccd2701639
--- /dev/null
+++ b/x11-misc/xpad/xpad-4.9.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="a sticky note application for jotting down things to remember"
+HOMEPAGE="https://launchpad.net/xpad"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ dev-libs/glib:2
+ app-accessibility/at-spi2-atk
+ dev-libs/atk
+ sys-devel/gettext
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3[X]
+ x11-libs/gtksourceview:3.0
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/pango
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-util/intltool-0.31
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}