summaryrefslogtreecommitdiff
path: root/x11-misc/xowl/xowl-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/xowl/xowl-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/xowl/xowl-9999.ebuild')
-rw-r--r--x11-misc/xowl/xowl-9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-misc/xowl/xowl-9999.ebuild b/x11-misc/xowl/xowl-9999.ebuild
new file mode 100644
index 000000000000..d4d0a425dfb7
--- /dev/null
+++ b/x11-misc/xowl/xowl-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic git-r3 savedconfig toolchain-funcs
+
+DESCRIPTION="X11 Obstinate Window Lister"
+HOMEPAGE="https://github.com/seanpringle/xowl"
+EGIT_REPO_URI="https://github.com/seanpringle/xowl"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXinerama
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_prepare() {
+ default
+ restore_config config.h
+}
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+}
+
+src_compile() {
+ XOAT_COMPILE=(
+ ${CC} -o ${PN} ${PN}.c ${CFLAGS} -std=c99 ${LDFLAGS}
+ $(${PKG_CONFIG} --cflags --libs x11 xft xinerama)
+ )
+ echo ${XOAT_COMPILE[@]}
+ ${XOAT_COMPILE[@]} || die
+}
+
+src_install() {
+ dobin xowl
+ dodoc xowl.md
+ doman xowl.1
+ save_config config.h
+}