summaryrefslogtreecommitdiff
path: root/x11-misc/xkeycaps/xkeycaps-2.47-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/xkeycaps/xkeycaps-2.47-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/xkeycaps/xkeycaps-2.47-r2.ebuild')
-rw-r--r--x11-misc/xkeycaps/xkeycaps-2.47-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-misc/xkeycaps/xkeycaps-2.47-r2.ebuild b/x11-misc/xkeycaps/xkeycaps-2.47-r2.ebuild
new file mode 100644
index 000000000000..504fde9935bc
--- /dev/null
+++ b/x11-misc/xkeycaps/xkeycaps-2.47-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="GUI frontend to xmodmap"
+HOMEPAGE="https://packages.qa.debian.org/x/xkeycaps.html"
+SRC_URI="mirror://debian/pool/main/x/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND="x11-misc/xbitmaps
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXaw
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-misc/imake
+ >=sys-apps/sed-4"
+
+DOCS=( README defining.txt hierarchy.txt sgi-microsoft.txt )
+PATCHES=(
+ "${FILESDIR}"/${P}-Imakefile.patch
+ "${FILESDIR}"/${P}-man.patch
+)
+
+src_compile() {
+ xmkmf || die
+ sed -i -e "s,all:: xkeycaps.\$(MANSUFFIX).html,all:: ,g" \
+ Makefile || die
+ emake EXTRA_LDOPTIONS="${LDFLAGS}" CC="$(tc-getCC)" \
+ CDEBUGFLAGS="${CFLAGS}"
+}
+
+src_install () {
+ default
+ newman ${PN}.man ${PN}.1
+}