summaryrefslogtreecommitdiff
path: root/x11-misc/xkbset/xkbset-0.5_p7_p1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /x11-misc/xkbset/xkbset-0.5_p7_p1.ebuild
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'x11-misc/xkbset/xkbset-0.5_p7_p1.ebuild')
-rw-r--r--x11-misc/xkbset/xkbset-0.5_p7_p1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-misc/xkbset/xkbset-0.5_p7_p1.ebuild b/x11-misc/xkbset/xkbset-0.5_p7_p1.ebuild
new file mode 100644
index 000000000000..47ac617ee117
--- /dev/null
+++ b/x11-misc/xkbset/xkbset-0.5_p7_p1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DEBIAN_P=${PV#*_p}
+DEBIAN_P=${DEBIAN_P/_p/.}
+
+DESCRIPTION="User preference utility for XKB extensions for X"
+HOMEPAGE="https://faculty.missouri.edu/~stephen/software/#xkbset"
+SRC_URI="
+ https://faculty.missouri.edu/~stephen/software/${PN}/${P/_p*/}.tar.gz
+ mirror://debian/pool/main/x/${PN}/${PN}_${PV/_p*/}-${DEBIAN_P}.debian.tar.xz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="tk"
+
+CDEPEND="
+ x11-libs/libX11
+"
+DEPEND="
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ tk? ( dev-perl/Tk )
+"
+
+S=${WORKDIR}/${P/_p*/}
+
+PATCHES=(
+ "${FILESDIR}"/${P/_p*/}-ldflags.patch
+ "${WORKDIR}"/debian/patches/02-clarify-errors.patch
+)
+
+src_compile() {
+ emake CC=$(tc-getCC) INC_PATH= LIB_PATH=
+}
+
+src_install() {
+ dobin xkbset
+ use tk && dobin xkbset-gui
+ doman xkbset.1
+ dodoc README TODO
+}