summaryrefslogtreecommitdiff
path: root/x11-misc/xkbd/xkbd-0.8.18.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /x11-misc/xkbd/xkbd-0.8.18.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'x11-misc/xkbd/xkbd-0.8.18.ebuild')
-rw-r--r--x11-misc/xkbd/xkbd-0.8.18.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/xkbd/xkbd-0.8.18.ebuild b/x11-misc/xkbd/xkbd-0.8.18.ebuild
new file mode 100644
index 000000000000..d7baae0ef8c1
--- /dev/null
+++ b/x11-misc/xkbd/xkbd-0.8.18.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic
+
+DESCRIPTION="onscreen soft keyboard for X11"
+HOMEPAGE="https://github.com/mahatma-kaganovich/xkbd"
+SRC_URI="https://github.com/mahatma-kaganovich/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="debug +xft +xpm"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXtst
+ xft? ( x11-libs/libXft )
+ xpm? ( x11-libs/libXpm )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+DOCS=( AUTHORS )
+S=${WORKDIR}/${PN}-${P}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use debug && append-cppflags -DDEBUG
+ econf \
+ $(use_enable xft) \
+ $(use_enable xpm) \
+ --disable-debug
+}