summaryrefslogtreecommitdiff
path: root/x11-misc/xhkeys/xhkeys-2.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/xhkeys/xhkeys-2.2.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/xhkeys/xhkeys-2.2.1.ebuild')
-rw-r--r--x11-misc/xhkeys/xhkeys-2.2.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-misc/xhkeys/xhkeys-2.2.1.ebuild b/x11-misc/xhkeys/xhkeys-2.2.1.ebuild
new file mode 100644
index 000000000000..e4c4db3ec3a4
--- /dev/null
+++ b/x11-misc/xhkeys/xhkeys-2.2.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="assign particular actions to any key or key combination"
+HOMEPAGE="http://wmalms.tripod.com/#XHKEYS"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+"
+DEPEND="
+ ${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-linux_headers.patch
+ "${FILESDIR}"/${P}-CC.patch
+)
+
+src_install() {
+ dobin xhkeys xhkconf
+ dodoc README VERSION
+}