summaryrefslogtreecommitdiff
path: root/x11-misc/xgestures/xgestures-0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/xgestures/xgestures-0.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/xgestures/xgestures-0.4.ebuild')
-rw-r--r--x11-misc/xgestures/xgestures-0.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-misc/xgestures/xgestures-0.4.ebuild b/x11-misc/xgestures/xgestures-0.4.ebuild
new file mode 100644
index 000000000000..a9921db7a5d5
--- /dev/null
+++ b/x11-misc/xgestures/xgestures-0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A mouse gesture recognition program for X11 desktops"
+HOMEPAGE="http://www.cs.bgu.ac.il/~tzachar/xgestures.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/libXmu
+ x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_install() {
+ default
+ newdoc .gestures gestures
+}
+
+pkg_postinst()
+{
+ elog "Unpack /usr/share/doc/${PF}/gestures* and copy it to \$HOME/.gestures"
+}