summaryrefslogtreecommitdiff
path: root/x11-misc/xfishtank/xfishtank-2.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /x11-misc/xfishtank/xfishtank-2.5.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'x11-misc/xfishtank/xfishtank-2.5.ebuild')
-rw-r--r--x11-misc/xfishtank/xfishtank-2.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/xfishtank/xfishtank-2.5.ebuild b/x11-misc/xfishtank/xfishtank-2.5.ebuild
new file mode 100644
index 000000000000..c98482c9096f
--- /dev/null
+++ b/x11-misc/xfishtank/xfishtank-2.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Turns your root window into an aquarium"
+HOMEPAGE="https://jim.rees.org/computers/xfishtank.html"
+SRC_URI="https://dev.gentoo.org/~jer/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-linux"
+
+RDEPEND="
+ media-libs/imlib2[X]
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ x11-misc/imake
+"
+S=${WORKDIR}/${PN}
+
+src_configure() {
+ xmkmf || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}" \
+ ${PN}
+}