summaryrefslogtreecommitdiff
path: root/x11-misc/xearth/xearth-1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/xearth/xearth-1.1-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/xearth/xearth-1.1-r1.ebuild')
-rw-r--r--x11-misc/xearth/xearth-1.1-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-misc/xearth/xearth-1.1-r1.ebuild b/x11-misc/xearth/xearth-1.1-r1.ebuild
new file mode 100644
index 000000000000..97ec7ce03faa
--- /dev/null
+++ b/x11-misc/xearth/xearth-1.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+HOMEPAGE="http://hewgill.com/xearth/original/"
+DESCRIPTION="Xearth sets the X root window to an image of the Earth"
+SRC_URI="ftp://cag.lcs.mit.edu/pub/tuna/${P}.tar.gz
+ ftp://ftp.cs.colorado.edu/users/tuna/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="xearth"
+KEYWORDS="alpha amd64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+"
+DEPEND="${RDEPEND}
+ x11-misc/imake
+ app-text/rman
+ x11-proto/xproto
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-include.patch
+}
+
+src_configure() {
+ xmkmf || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) \
+ CCOPTIONS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ newman xearth.man xearth.1
+ dobin xearth
+ dodoc BUILT-IN GAMMA-TEST HISTORY README
+}