summaryrefslogtreecommitdiff
path: root/x11-misc/xdialog/xdialog-2.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /x11-misc/xdialog/xdialog-2.3.1.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'x11-misc/xdialog/xdialog-2.3.1.ebuild')
-rw-r--r--x11-misc/xdialog/xdialog-2.3.1.ebuild29
1 files changed, 13 insertions, 16 deletions
diff --git a/x11-misc/xdialog/xdialog-2.3.1.ebuild b/x11-misc/xdialog/xdialog-2.3.1.ebuild
index 3be9830a8b33..e2052afacdc9 100644
--- a/x11-misc/xdialog/xdialog-2.3.1.ebuild
+++ b/x11-misc/xdialog/xdialog-2.3.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools eutils
+inherit autotools
-DESCRIPTION="drop-in replacement for cdialog using GTK"
+DESCRIPTION="Drop-in replacement for cdialog using GTK"
HOMEPAGE="http://xdialog.free.fr/"
SRC_URI="http://${PN}.free.fr/Xdialog-${PV}.tar.bz2"
@@ -18,21 +18,20 @@ RDEPEND="
dev-libs/glib:2
>=x11-libs/gtk+-2.2:2
"
-DEPEND="
- ${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
nls? ( sys-devel/gettext )
"
S="${WORKDIR}/${P/x/X}"
-PATCHES=(
- "${FILESDIR}"/${P}-{no-strip,install}.patch
-)
+DOCS=( AUTHORS BUGS ChangeLog README )
-src_prepare() {
- epatch "${PATCHES[@]}"
+PATCHES=( "${FILESDIR}"/${P}-{no-strip,install}.patch )
+src_prepare() {
+ default
eautoreconf
}
@@ -45,11 +44,9 @@ src_configure() {
src_install() {
default
- rm -rv "${D}"/usr/share/doc || die
-
- dodoc AUTHORS BUGS ChangeLog README
-
- use doc && dohtml -r doc/
+ rm -r "${D}"/usr/share/doc || die
+ use doc && local HTML_DOCS=( doc/. )
+ einstalldocs
if use examples; then
insinto "/usr/share/doc/${PF}/examples"