summaryrefslogtreecommitdiff
path: root/x11-misc/xdialog/xdialog-2.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/xdialog/xdialog-2.3.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/xdialog/xdialog-2.3.1.ebuild')
-rw-r--r--x11-misc/xdialog/xdialog-2.3.1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/x11-misc/xdialog/xdialog-2.3.1.ebuild b/x11-misc/xdialog/xdialog-2.3.1.ebuild
new file mode 100644
index 000000000000..b98cd8fbe72b
--- /dev/null
+++ b/x11-misc/xdialog/xdialog-2.3.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="drop-in replacement for cdialog using GTK"
+HOMEPAGE="http://xdialog.free.fr/"
+SRC_URI="http://${PN}.free.fr/Xdialog-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ppc x86"
+IUSE="doc examples nls"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=x11-libs/gtk+-2.2:2
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+S="${WORKDIR}/${P/x/X}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-{no-strip,install}.patch
+)
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --with-gtk2
+}
+
+src_install() {
+ default
+
+ rm -rv "${D}"/usr/share/doc || die
+
+ dodoc AUTHORS BUGS ChangeLog README
+
+ use doc && dohtml -r doc/
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins samples/*
+ fi
+}