summaryrefslogtreecommitdiff
path: root/x11-misc/xdesktopwaves/xdesktopwaves-1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /x11-misc/xdesktopwaves/xdesktopwaves-1.4.ebuild
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'x11-misc/xdesktopwaves/xdesktopwaves-1.4.ebuild')
-rw-r--r--x11-misc/xdesktopwaves/xdesktopwaves-1.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/xdesktopwaves/xdesktopwaves-1.4.ebuild b/x11-misc/xdesktopwaves/xdesktopwaves-1.4.ebuild
new file mode 100644
index 000000000000..901b11eb7789
--- /dev/null
+++ b/x11-misc/xdesktopwaves/xdesktopwaves-1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit desktop toolchain-funcs
+
+DESCRIPTION="A cellular automata setting the background of your X Windows desktop under water"
+HOMEPAGE="http://xdesktopwaves.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+RDEPEND="
+ x11-libs/libXext
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4-gentoo.patch
+)
+
+src_compile() {
+ tc-export CC PKG_CONFIG
+ emake
+ emake -C xdwapi
+}
+
+src_install() {
+ dobin xdesktopwaves xdwapi/xdwapidemo
+ doman xdesktopwaves.1
+ insinto /usr/share/pixmaps
+ doins xdesktopwaves.xpm
+ make_desktop_entry xdesktopwaves
+ einstalldocs
+}