summaryrefslogtreecommitdiff
path: root/x11-misc/xdesktopwaves/xdesktopwaves-1.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/xdesktopwaves/xdesktopwaves-1.3-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/xdesktopwaves/xdesktopwaves-1.3-r2.ebuild')
-rw-r--r--x11-misc/xdesktopwaves/xdesktopwaves-1.3-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-misc/xdesktopwaves/xdesktopwaves-1.3-r2.ebuild b/x11-misc/xdesktopwaves/xdesktopwaves-1.3-r2.ebuild
new file mode 100644
index 000000000000..cf84faf3f802
--- /dev/null
+++ b/x11-misc/xdesktopwaves/xdesktopwaves-1.3-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A cellular automata setting the background of your X Windows desktop under water"
+HOMEPAGE="http://xdesktopwaves.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+RDEPEND="x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_compile() {
+ tc-export CC
+ emake
+ emake -C xdwapi
+}
+
+src_install() {
+ dobin xdesktopwaves xdwapi/xdwapidemo
+ doman xdesktopwaves.1
+ insinto /usr/share/pixmaps
+ doins xdesktopwaves.xpm
+ make_desktop_entry xdesktopwaves
+ einstalldocs
+}
+
+pkg_preinst() {
+ elog "To see what xdesktopwaves is able to do, start it by running"
+ elog "'xdesktopwaves' and then run 'xdwapidemo'. You should see the"
+ elog "supported effects on your desktop"
+}