summaryrefslogtreecommitdiff
path: root/x11-misc/xdesktopwaves/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/xdesktopwaves/files
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/xdesktopwaves/files')
-rw-r--r--x11-misc/xdesktopwaves/files/xdesktopwaves-1.3-gentoo.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/xdesktopwaves/files/xdesktopwaves-1.3-gentoo.patch b/x11-misc/xdesktopwaves/files/xdesktopwaves-1.3-gentoo.patch
new file mode 100644
index 000000000000..accbb4d9baec
--- /dev/null
+++ b/x11-misc/xdesktopwaves/files/xdesktopwaves-1.3-gentoo.patch
@@ -0,0 +1,38 @@
+--- xdesktopwaves-1.3/Makefile.org 2004-12-18 06:47:40.000000000 +0100
++++ xdesktopwaves-1.3/Makefile 2010-02-08 20:05:31.000000000 +0100
+@@ -11,14 +11,13 @@
+
+ #=========================== C compiler configuration ==========================
+
+-CC = gcc
+-CFLAGS = -I/usr/X11R6/include -O2
++CFLAGS += $(shell pkg-config --cflags x11 xext)
+
+ #============================= Linker configuration ============================
+
+-LINK = gcc
+-LFLAGS = -L/usr/X11R6/lib
+-LIBS = -lm -lX11 -lXext
++LINK = $(CC)
++LFLAGS = $(LDFLAGS)
++LIBS = -lm $(shell pkg-config --libs x11 xext)
+
+ #============================ Installer configuration ==========================
+
+--- xdesktopwaves-1.3/xdwapi/Makefile.org 2004-12-18 06:47:40.000000000 +0100
++++ xdesktopwaves-1.3/xdwapi/Makefile 2010-02-08 20:08:14.000000000 +0100
+@@ -1,10 +1,9 @@
+ # Makefile for the xdesktopwaves API and its demo program
+
+-CC = gcc
+-CFLAGS = -I/usr/X11R6/include -O2
+-LINK = gcc
+-LFLAGS = -L/usr/X11R6/lib
+-LIBS = -lm -lX11
++CFLAGS += $(shell pkg-config --cflags x11 xext)
++LINK = $(CC)
++LFLAGS = $(LDFLAGS)
++LIBS = -lm $(shell pkg-config --libs x11 xext)
+
+ all: xdwapidemo
+