summaryrefslogtreecommitdiff
path: root/x11-misc/xcompmgr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /x11-misc/xcompmgr
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'x11-misc/xcompmgr')
-rw-r--r--x11-misc/xcompmgr/Manifest1
-rw-r--r--x11-misc/xcompmgr/xcompmgr-1.1.7-r1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/x11-misc/xcompmgr/Manifest b/x11-misc/xcompmgr/Manifest
index e1c12e5a210f..ac0363459a9f 100644
--- a/x11-misc/xcompmgr/Manifest
+++ b/x11-misc/xcompmgr/Manifest
@@ -1,3 +1,4 @@
DIST xcompmgr-1.1.7.tar.bz2 136667 BLAKE2B 3231cca0cebc13aade6f008414d77461913d274303289c28b8eb366640905cf9bbb4715d5aa7ad8eb897ac94db099b040e408b2e3867dd2ad46940b3bcfe518f SHA512 f93a6be78169dd41ff08d71409e28746fd62902810a2f6930c0ac44f1415bc7391a8fb885b074fd40afedd7f1c1590aa7c67fc101c3b6488ddaa74495b42149c
+EBUILD xcompmgr-1.1.7-r1.ebuild 911 BLAKE2B 697a60c13fc12819fcd418e2b39325d2ca4b85a896296413144a195fcac821a40cf777096a8c041fe2884981ea9ba7e2aa6c9cd02640daa8acc0a2f3a096aa99 SHA512 6b9658a761f2b2ab10a60dad9a0b7345e569cac84ae158f339718455a2caa5449d8f435a8c887a8ec74732a2304756a1f706c76692021795c867d0a68998769a
EBUILD xcompmgr-1.1.7.ebuild 500 BLAKE2B d0876987205a64069657b80700578fc71c137f75a73b12034d1e2bb442eec8088682884c21a6b3cfaa353f7b903a7df22712fa3add2f30ede15a27c09565b7f9 SHA512 5e62cbc526635fff3dc68f8a0b038ed0e8197e675ffec37a3abb8ab8aed8666e0e5ad35522e8e6852ba1ac99bc5a42aec4a417d1a68a5aafbdefe5026a9b4aa3
MISC metadata.xml 230 BLAKE2B 70bf59e64305ef14908197f2aa7ffbc1769ade265097da68e001245451658af5921760c91cb74aae717543ea0017e2471fd94bfc5c4c447d2d60e2c23aa3b007 SHA512 d7a2643abd1904cc5ff4d91cbb6f1baeb7f75fd1db542c5e14f19412f4f0bd4b903f8e703a7662ba7482c79dac5529057760b6427599d35e0842755fd946e057
diff --git a/x11-misc/xcompmgr/xcompmgr-1.1.7-r1.ebuild b/x11-misc/xcompmgr/xcompmgr-1.1.7-r1.ebuild
new file mode 100644
index 000000000000..c271eab9415b
--- /dev/null
+++ b/x11-misc/xcompmgr/xcompmgr-1.1.7-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="X Compositing manager"
+HOMEPAGE="https://freedesktop.org/wiki/Software/xapps"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/app/glxcompmgr.git"
+ inherit autotools git-r3
+ # x11-misc-util/macros only required on live ebuilds
+ LIVE_DEPEND=">=x11-misc/util-macros-1.18"
+else
+ SRC_URI="mirror://xorg/app/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ x11-libs/libXrender
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ x11-libs/libXcomposite
+ x11-libs/libXext
+"
+DEPEND="
+ ${LIVE_DEPEND}
+ ${RDEPEND}
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ local econfargs=(
+ --disable-selective-werror
+ )
+
+ econf "${econfargs[@]}"
+}