summaryrefslogtreecommitdiff
path: root/x11-misc/xbindkeys/xbindkeys-1.8.7-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /x11-misc/xbindkeys/xbindkeys-1.8.7-r2.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'x11-misc/xbindkeys/xbindkeys-1.8.7-r2.ebuild')
-rw-r--r--x11-misc/xbindkeys/xbindkeys-1.8.7-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-misc/xbindkeys/xbindkeys-1.8.7-r2.ebuild b/x11-misc/xbindkeys/xbindkeys-1.8.7-r2.ebuild
new file mode 100644
index 000000000000..3eba2a59a23a
--- /dev/null
+++ b/x11-misc/xbindkeys/xbindkeys-1.8.7-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Tool for launching commands on keystrokes"
+SRC_URI="https://www.nongnu.org/${PN}/${P}.tar.gz"
+HOMEPAGE="https://www.nongnu.org/xbindkeys/xbindkeys.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="guile tk"
+
+RDEPEND="
+ x11-libs/libX11
+ guile? ( >=dev-scheme/guile-1.8.4:=[deprecated] )
+ tk? ( dev-lang/tk )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+DOCS=( AUTHORS BUGS ChangeLog README TODO xbindkeysrc )
+
+src_prepare() {
+ default
+
+ # Regenerate to pick up newer versions of Guile macros
+ # bug #828532
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable guile) \
+ $(use_enable tk)
+}