summaryrefslogtreecommitdiff
path: root/x11-misc/wdm/wdm-1.28-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/wdm/wdm-1.28-r4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/wdm/wdm-1.28-r4.ebuild')
-rw-r--r--x11-misc/wdm/wdm-1.28-r4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-misc/wdm/wdm-1.28-r4.ebuild b/x11-misc/wdm/wdm-1.28-r4.ebuild
new file mode 100644
index 000000000000..cdcecc0c486f
--- /dev/null
+++ b/x11-misc/wdm/wdm-1.28-r4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit pam
+
+DESCRIPTION="WINGs Display Manager"
+HOMEPAGE="https://github.com/voins/wdm"
+SRC_URI="http://voins.program.ru/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ~ppc64 ~sparc x86"
+IUSE="pam selinux truetype"
+
+COMMON_DEPEND=">=x11-wm/windowmaker-0.70.0
+ truetype? ( x11-libs/libXft )
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXpm
+ pam? ( virtual/pam )"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext"
+RDEPEND="${COMMON_DEPEND}
+ pam? ( >=sys-auth/pambase-20080219.1 )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-terminateServer.patch
+ "${FILESDIR}"/${P}-remove-fakehome.patch
+)
+
+src_configure() {
+ econf \
+ --with-wdmdir="${EPREFIX}"/etc/X11/wdm \
+ $(use_enable pam) \
+ $(use_enable selinux)
+}
+
+src_install() {
+ default
+
+ rm -f "${ED%/}"/etc/pam.d/wdm || die
+ pamd_mimic system-local-login wdm auth account password session
+}