summaryrefslogtreecommitdiff
path: root/x11-misc/wbar/wbar-2.3.4-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /x11-misc/wbar/wbar-2.3.4-r3.ebuild
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'x11-misc/wbar/wbar-2.3.4-r3.ebuild')
-rw-r--r--x11-misc/wbar/wbar-2.3.4-r3.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/x11-misc/wbar/wbar-2.3.4-r3.ebuild b/x11-misc/wbar/wbar-2.3.4-r3.ebuild
new file mode 100644
index 000000000000..f46e060720dc
--- /dev/null
+++ b/x11-misc/wbar/wbar-2.3.4-r3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools bash-completion-r1
+
+DESCRIPTION="A fast, lightweight quick launch bar"
+HOMEPAGE="https://github.com/rodolf0/wbar"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="gtk"
+RDEPEND="
+ media-libs/imlib2[X]
+ x11-libs/libX11
+ gtk? (
+ dev-libs/glib
+ gnome-base/libglade
+ media-libs/freetype:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3.3-desktopfile.patch
+ "${FILESDIR}"/${PN}-2.3.3-nowerror.patch
+ "${FILESDIR}"/${PN}-2.3.3-test.patch
+ "${FILESDIR}"/${PN}-2.3.4-automake-1.13.patch
+ "${FILESDIR}"/${PN}-2.3.4-c++11.patch
+ "${FILESDIR}"/${PN}-2.3.4-completion.patch
+)
+
+src_prepare() {
+ default
+
+ use gtk || eapply "${FILESDIR}"/${PN}-2.3.4-gtk.patch
+
+ sed -i \
+ -e "/^bashcompletiondir/s:=.*$:=$(get_bashcompdir):" \
+ etc/Makefile.am || die #482358
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable gtk wbar-config)
+}