summaryrefslogtreecommitdiff
path: root/x11-misc/vdpauinfo/vdpauinfo-1.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-10 14:18:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-10 14:18:01 +0100
commite9c5cd3a9230f2f3f5980a5ca0c4ec20c099c7ed (patch)
treed7c270e41be9693c41fdb4ce3833f7dd151d95b2 /x11-misc/vdpauinfo/vdpauinfo-1.5-r1.ebuild
parentc2968b21192246c8fa4e99d5a2944658096f868e (diff)
gentoo auto-resync : 10:08:2022 - 14:18:00
Diffstat (limited to 'x11-misc/vdpauinfo/vdpauinfo-1.5-r1.ebuild')
-rw-r--r--x11-misc/vdpauinfo/vdpauinfo-1.5-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-misc/vdpauinfo/vdpauinfo-1.5-r1.ebuild b/x11-misc/vdpauinfo/vdpauinfo-1.5-r1.ebuild
new file mode 100644
index 000000000000..985ed1288c27
--- /dev/null
+++ b/x11-misc/vdpauinfo/vdpauinfo-1.5-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Displays info about your card's VDPAU support"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/VDPAU"
+SRC_URI="https://gitlab.freedesktop.org/vdpau/vdpauinfo/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ >=x11-libs/libvdpau-1.5
+ x11-libs/libX11"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ eautoreconf
+
+ append-flags -fno-strict-aliasing #864755
+}