summaryrefslogtreecommitdiff
path: root/x11-misc/tdrop/tdrop-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /x11-misc/tdrop/tdrop-0.5.0.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'x11-misc/tdrop/tdrop-0.5.0.ebuild')
-rw-r--r--x11-misc/tdrop/tdrop-0.5.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-misc/tdrop/tdrop-0.5.0.ebuild b/x11-misc/tdrop/tdrop-0.5.0.ebuild
new file mode 100644
index 000000000000..252c3456998e
--- /dev/null
+++ b/x11-misc/tdrop/tdrop-0.5.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="WM-Independent Dropdown Creator"
+HOMEPAGE="https://github.com/noctuid/tdrop"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/noctuid/tdrop"
+else
+ SRC_URI="https://github.com/noctuid/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ app-shells/bash
+ sys-apps/gawk
+ sys-process/procps
+ x11-apps/xprop
+ x11-apps/xrandr
+ x11-apps/xwininfo
+ x11-misc/xdotool
+"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dobin tdrop
+ doman tdrop.1
+ dodoc README.org
+}
+
+pkg_postinst() {
+ optfeature "tmux session support" app-misc/tmux
+}