summaryrefslogtreecommitdiff
path: root/x11-misc/synergy/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
commitea31ad0ed5501d0bf92267c35beaf06ac016bad2 (patch)
tree2fdc433d571e3ead010876d43ce2646b7d783680 /x11-misc/synergy/files
parent88ebe56470c37b02a044e1091cad6b2df0f3be8f (diff)
gentoo resync : 13.05.2018
Diffstat (limited to 'x11-misc/synergy/files')
-rw-r--r--x11-misc/synergy/files/synergy-1.4.16_p1969-pthread.patch11
-rw-r--r--x11-misc/synergy/files/synergy-1.4.17_p2055-CSocketMultiplexer.patch13
-rw-r--r--x11-misc/synergy/files/synergy-1.4.17_p2055-cryptopp.patch96
-rw-r--r--x11-misc/synergy/files/synergy-1.4.17_p2055-gentoo.patch11
-rw-r--r--x11-misc/synergy/files/synergy-1.4.17_p2055-test.patch33
-rw-r--r--x11-misc/synergy/files/synergy-1.7.5-gentoo.patch11
-rw-r--r--x11-misc/synergy/files/synergy-1.8.1-internal-gmock-gtest.patch23
-rw-r--r--x11-misc/synergy/files/synergy-1.8.5-gtest.patch38
-rw-r--r--x11-misc/synergy/files/synergy-1.9.1-cmake-version.patch57
-rw-r--r--x11-misc/synergy/files/synergy-1.9.1-gtest.patch28
-rw-r--r--x11-misc/synergy/files/synergy-1.9.1-internal-gmock-gtest.patch23
-rw-r--r--x11-misc/synergy/files/synergy-1.9.1-pthread.patch11
-rw-r--r--x11-misc/synergy/files/synergy-1.9.1-qt-5.11.patch31
13 files changed, 150 insertions, 236 deletions
diff --git a/x11-misc/synergy/files/synergy-1.4.16_p1969-pthread.patch b/x11-misc/synergy/files/synergy-1.4.16_p1969-pthread.patch
deleted file mode 100644
index adddf2f73b67..000000000000
--- a/x11-misc/synergy/files/synergy-1.4.16_p1969-pthread.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -141,6 +141,8 @@
- check_library_exists("pthread" pthread_create "" HAVE_PTHREAD)
- if (HAVE_PTHREAD)
- list(APPEND libs pthread)
-+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pthread")
-+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pthread")
- else()
- message(FATAL_ERROR "Missing library: pthread")
- endif()
diff --git a/x11-misc/synergy/files/synergy-1.4.17_p2055-CSocketMultiplexer.patch b/x11-misc/synergy/files/synergy-1.4.17_p2055-CSocketMultiplexer.patch
deleted file mode 100644
index 0e99fd3bce5d..000000000000
--- a/x11-misc/synergy/files/synergy-1.4.17_p2055-CSocketMultiplexer.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-http://synergy-project.org/spit/issues/details/2935/
-https://bugs.gentoo.org/show_bug.cgi?id=505978
-
---- a/src/lib/net/SocketMultiplexer.cpp
-+++ b/src/lib/net/SocketMultiplexer.cpp
-@@ -243,6 +243,7 @@
- for (CSocketJobMap::iterator i = m_socketJobMap.begin();
- i != m_socketJobMap.end();) {
- if (*(i->second) == NULL) {
-+ m_socketJobs.erase(i->second);
- m_socketJobMap.erase(i++);
- m_update = true;
- }
diff --git a/x11-misc/synergy/files/synergy-1.4.17_p2055-cryptopp.patch b/x11-misc/synergy/files/synergy-1.4.17_p2055-cryptopp.patch
deleted file mode 100644
index 59f85a9c29a0..000000000000
--- a/x11-misc/synergy/files/synergy-1.4.17_p2055-cryptopp.patch
+++ /dev/null
@@ -1,96 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -145,6 +145,10 @@
- check_type_size(long SIZEOF_LONG)
- check_type_size(short SIZEOF_SHORT)
-
-+ set(CMAKE_REQUIRED_LIBRARIES crypto++)
-+ set(CMAKE_REQUIRED_LIBRARIES)
-+ set(CMAKE_INCLUDE_DIRECTORIES)
-+
- # pthread is used on both Linux and Mac
- check_library_exists("pthread" pthread_create "" HAVE_PTHREAD)
- if (HAVE_PTHREAD)
---- a/ext/CMakeLists.txt
-+++ b/ext/CMakeLists.txt
-@@ -13,47 +13,6 @@
- # You should have received a copy of the GNU General Public License
- # along with this program. If not, see <http://www.gnu.org/licenses/>.
-
--set(cryptopp_dir cryptopp562)
--
--# only compile the crypto++ files we need.
--set(cryptopp_src
-- ${cryptopp_dir}/3way.cpp
-- ${cryptopp_dir}/algparam.cpp
-- ${cryptopp_dir}/asn.cpp
-- ${cryptopp_dir}/authenc.cpp
-- ${cryptopp_dir}/basecode.cpp
-- ${cryptopp_dir}/cpu.cpp
-- ${cryptopp_dir}/cryptlib.cpp
-- ${cryptopp_dir}/des.cpp
-- ${cryptopp_dir}/dessp.cpp
-- ${cryptopp_dir}/dll.cpp
-- ${cryptopp_dir}/ec2n.cpp
-- ${cryptopp_dir}/ecp.cpp
-- ${cryptopp_dir}/filters.cpp
-- ${cryptopp_dir}/fips140.cpp
-- ${cryptopp_dir}/gcm.cpp
-- ${cryptopp_dir}/gf2n.cpp
-- ${cryptopp_dir}/gfpcrypt.cpp
-- ${cryptopp_dir}/hex.cpp
-- ${cryptopp_dir}/hmac.cpp
-- ${cryptopp_dir}/hrtimer.cpp
-- ${cryptopp_dir}/integer.cpp
-- ${cryptopp_dir}/iterhash.cpp
-- ${cryptopp_dir}/misc.cpp
-- ${cryptopp_dir}/modes.cpp
-- ${cryptopp_dir}/mqueue.cpp
-- ${cryptopp_dir}/nbtheory.cpp
-- ${cryptopp_dir}/oaep.cpp
-- ${cryptopp_dir}/osrng.cpp
-- ${cryptopp_dir}/pubkey.cpp
-- ${cryptopp_dir}/queue.cpp
-- ${cryptopp_dir}/randpool.cpp
-- ${cryptopp_dir}/rdtables.cpp
-- ${cryptopp_dir}/rijndael.cpp
-- ${cryptopp_dir}/rng.cpp
-- ${cryptopp_dir}/sha.cpp
--)
--
- # if 64-bit windows, compile asm file.
- if (CMAKE_CL_64)
- list(APPEND cryptopp_src ${cryptopp_dir}/x64dll.asm ${cryptopp_dir}/x64masm.asm)
-@@ -87,10 +46,3 @@
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -march=${CRYPTOPP_ARCH}")
- endif()
- endif()
--
--add_library(cryptopp STATIC ${cryptopp_src})
--
--if (UNIX)
-- # ignore warnings in crypto++
-- set_target_properties(cryptopp PROPERTIES COMPILE_FLAGS "-w")
--endif()
---- a/src/lib/io/CryptoMode_cryptopp.h
-+++ b/src/lib/io/CryptoMode_cryptopp.h
-@@ -25,6 +25,6 @@
- # pragma GCC system_header
- #endif
-
--#include <cryptopp562/gcm.h>
--#include <cryptopp562/modes.h>
--#include <cryptopp562/aes.h>
-+#include <crypto++/gcm.h>
-+#include <crypto++/modes.h>
-+#include <crypto++/aes.h>
---- a/src/lib/io/CryptoStream_cryptopp.h
-+++ b/src/lib/io/CryptoStream_cryptopp.h
-@@ -25,5 +25,5 @@
- # pragma GCC system_header
- #endif
-
--#include <cryptopp562/osrng.h>
--#include <cryptopp562/sha.h>
-+#include <crypto++/osrng.h>
-+#include <crypto++/sha.h>
diff --git a/x11-misc/synergy/files/synergy-1.4.17_p2055-gentoo.patch b/x11-misc/synergy/files/synergy-1.4.17_p2055-gentoo.patch
deleted file mode 100644
index 89f46f3c9af0..000000000000
--- a/x11-misc/synergy/files/synergy-1.4.17_p2055-gentoo.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -77,7 +77,7 @@
-
- # warnings as errors:
- # we have a problem with people checking in code with warnings.
-- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
-+ #set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
-
- # For config.h, detect the libraries, functions, etc.
- include(CheckIncludeFiles)
diff --git a/x11-misc/synergy/files/synergy-1.4.17_p2055-test.patch b/x11-misc/synergy/files/synergy-1.4.17_p2055-test.patch
deleted file mode 100644
index e0e25c2e128b..000000000000
--- a/x11-misc/synergy/files/synergy-1.4.17_p2055-test.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -19,6 +19,6 @@
- add_subdirectory(plugin)
- add_subdirectory(micro)
-
--if (NOT ${CMAKE_SYSTEM_NAME} MATCHES "IRIX")
-+if (${WITH_GENTOO_TEST} MATCHES "ON")
- add_subdirectory(test)
- endif()
---- a/src/test/CMakeLists.txt
-+++ b/src/test/CMakeLists.txt
-@@ -14,20 +14,5 @@
- # You should have received a copy of the GNU General Public License
- # along with this program. If not, see <http://www.gnu.org/licenses/>.
-
--include_directories(
-- ../../ext/gtest-1.6.0
-- ../../ext/gtest-1.6.0/include
-- ../../ext/gmock-1.6.0
-- ../../ext/gmock-1.6.0/include)
--
--add_library(gtest STATIC ../../ext/gtest-1.6.0/src/gtest-all.cc)
--add_library(gmock STATIC ../../ext/gmock-1.6.0/src/gmock-all.cc)
--
--if (UNIX)
-- # ignore warnings in gtest and gmock
-- set_target_properties(gtest PROPERTIES COMPILE_FLAGS "-w")
-- set_target_properties(gmock PROPERTIES COMPILE_FLAGS "-w")
--endif()
--
- add_subdirectory(integtests)
- add_subdirectory(unittests)
diff --git a/x11-misc/synergy/files/synergy-1.7.5-gentoo.patch b/x11-misc/synergy/files/synergy-1.7.5-gentoo.patch
deleted file mode 100644
index 9c508f68eeef..000000000000
--- a/x11-misc/synergy/files/synergy-1.7.5-gentoo.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -80,7 +80,7 @@
-
- # warnings as errors:
- # we have a problem with people checking in code with warnings.
-- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror -Wno-unused-local-typedef")
-+ #set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror -Wno-unused-local-typedef")
-
- # For config.h, detect the libraries, functions, etc.
- include(CheckIncludeFiles)
diff --git a/x11-misc/synergy/files/synergy-1.8.1-internal-gmock-gtest.patch b/x11-misc/synergy/files/synergy-1.8.1-internal-gmock-gtest.patch
deleted file mode 100644
index 7814c7418cd3..000000000000
--- a/x11-misc/synergy/files/synergy-1.8.1-internal-gmock-gtest.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/src/test/CMakeLists.txt
-+++ b/src/test/CMakeLists.txt
-@@ -14,20 +14,5 @@
- # You should have received a copy of the GNU General Public License
- # along with this program. If not, see <http://www.gnu.org/licenses/>.
-
--include_directories(
-- ../../ext/gtest-1.6.0
-- ../../ext/gtest-1.6.0/include
-- ../../ext/gmock-1.6.0
-- ../../ext/gmock-1.6.0/include)
--
--add_library(gtest STATIC ../../ext/gtest-1.6.0/src/gtest-all.cc)
--add_library(gmock STATIC ../../ext/gmock-1.6.0/src/gmock-all.cc)
--
--if (UNIX)
-- # ignore warnings in gtest and gmock
-- set_target_properties(gtest PROPERTIES COMPILE_FLAGS "-w")
-- set_target_properties(gmock PROPERTIES COMPILE_FLAGS "-w")
--endif()
--
- add_subdirectory(integtests)
- add_subdirectory(unittests)
diff --git a/x11-misc/synergy/files/synergy-1.8.5-gtest.patch b/x11-misc/synergy/files/synergy-1.8.5-gtest.patch
deleted file mode 100644
index 69391b217db2..000000000000
--- a/x11-misc/synergy/files/synergy-1.8.5-gtest.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- a/src/lib/synergy/KeyMap.h
-+++ b/src/lib/synergy/KeyMap.h
-@@ -24,7 +24,9 @@
- #include "common/stdset.h"
- #include "common/stdvector.h"
-
-+#if WITH_GENTOO_TEST
- #include "gtest/gtest_prod.h"
-+#endif
-
- namespace synergy {
-
-@@ -327,6 +329,7 @@
- //@}
-
-
-+#if WITH_GENTOO_TEST
- private:
- FRIEND_TEST(KeyMapTests,
- findBestKey_requiredDown_matchExactFirstItem);
-@@ -341,6 +344,7 @@
- FRIEND_TEST(KeyMapTests,
- findBestKey_onlyOneRequiredDown_matchTwoRequiredChangesItem);
- FRIEND_TEST(KeyMapTests, findBestKey_noRequiredDown_cannotMatch);
-+#endif
-
- private:
- //! Ways to synthesize a key
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -50,6 +50,6 @@
- add_subdirectory(cmd)
- add_subdirectory(micro)
-
--if (NOT ${CMAKE_SYSTEM_NAME} MATCHES "IRIX")
-+if (${WITH_GENTOO_TEST})
- add_subdirectory(test)
- endif()
diff --git a/x11-misc/synergy/files/synergy-1.9.1-cmake-version.patch b/x11-misc/synergy/files/synergy-1.9.1-cmake-version.patch
new file mode 100644
index 000000000000..da7a603119d3
--- /dev/null
+++ b/x11-misc/synergy/files/synergy-1.9.1-cmake-version.patch
@@ -0,0 +1,57 @@
+--- a/cmake/Version.cmake 2018-04-10 12:18:42.000000000 +0200
++++ b/cmake/Version.cmake 2018-05-11 23:29:24.499906356 +0200
+@@ -23,7 +23,7 @@
+ if (DEFINED ENV{SYNERGY_VERSION_PATCH})
+ set (SYNERGY_VERSION_PATCH $ENV{SYNERGY_VERSION_PATCH})
+ else()
+- set (SYNERGY_VERSION_PATCH 0)
++ set (SYNERGY_VERSION_PATCH 1)
+ message (WARNING "Synergy version wasn't set. Set to ${SYNERGY_VERSION_MAJOR}.${SYNERGY_VERSION_MINOR}.${SYNERGY_VERSION_PATCH}")
+ endif()
+ endif()
+@@ -36,29 +36,6 @@
+ endif()
+ endif()
+
+-if (NOT DEFINED SYNERGY_REVISION)
+- if (DEFINED ENV{GIT_COMMIT})
+- string (SUBSTRING $ENV{GIT_COMMIT} 0 8 SYNERGY_REVISION)
+- elseif (SYNERGY_VERSION_STAGE STREQUAL "snapshot")
+- execute_process (
+- COMMAND git rev-parse --short=8 HEAD
+- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
+- OUTPUT_VARIABLE SYNERGY_REVISION
+- OUTPUT_STRIP_TRAILING_WHITESPACE
+- )
+- endif()
+-endif()
+-
+-if (DEFINED SYNERGY_REVISION)
+- string(LENGTH ${SYNERGY_REVISION} SYNERGY_REVISION_LENGTH)
+- if (NOT ((SYNERGY_REVISION MATCHES "^[a-f0-9]+") AND (SYNERGY_REVISION_LENGTH EQUAL "8")))
+- message (FATAL_ERROR "SYNERGY_REVISION ('${SYNERGY_REVISION}') should be a short commit hash")
+- endif()
+- unset (SYNERGY_REVISION_LENGTH)
+-else()
+- set (SYNERGY_REVISION "0badc0de")
+-endif()
+-
+ if (DEFINED ENV{BUILD_NUMBER})
+ set (SYNERGY_BUILD_NUMBER $ENV{BUILD_NUMBER})
+ else()
+@@ -66,7 +43,6 @@
+ endif()
+
+ string (TIMESTAMP SYNERGY_BUILD_DATE "%Y%m%d" UTC)
+-set (SYNERGY_SNAPSHOT_INFO ".${SYNERGY_VERSION_STAGE}.${SYNERGY_REVISION}")
+
+ if (SYNERGY_VERSION_STAGE STREQUAL "snapshot")
+ set (SYNERGY_VERSION_TAG "${SYNERGY_VERSION_STAGE}.b${SYNERGY_BUILD_NUMBER}-${SYNERGY_REVISION}")
+@@ -80,7 +56,6 @@
+
+ add_definitions (-DSYNERGY_VERSION="${SYNERGY_VERSION}")
+ add_definitions (-DSYNERGY_VERSION_STRING="${SYNERGY_VERSION_STRING}")
+-add_definitions (-DSYNERGY_REVISION="${SYNERGY_REVISION}")
+ add_definitions (-DSYNERGY_BUILD_DATE="${SYNERGY_BUILD_DATE}")
+ add_definitions (-DSYNERGY_BUILD_NUMBER=${SYNERGY_BUILD_NUMBER})
+
diff --git a/x11-misc/synergy/files/synergy-1.9.1-gtest.patch b/x11-misc/synergy/files/synergy-1.9.1-gtest.patch
new file mode 100644
index 000000000000..f7a5e614e810
--- /dev/null
+++ b/x11-misc/synergy/files/synergy-1.9.1-gtest.patch
@@ -0,0 +1,28 @@
+--- a/src/lib/synergy/KeyMap.h
++++ b/src/lib/synergy/KeyMap.h
+@@ -24,7 +24,9 @@
+ #include "common/stdset.h"
+ #include "common/stdvector.h"
+
++#if WITH_GENTOO_TEST
+ #include <gtest/gtest_prod.h>
++#endif
+
+ namespace synergy {
+
+@@ -327,6 +329,7 @@
+ //@}
+
+
++#if WITH_GENTOO_TEST
+ private:
+ FRIEND_TEST(KeyMapTests,
+ findBestKey_requiredDown_matchExactFirstItem);
+@@ -341,6 +344,7 @@
+ FRIEND_TEST(KeyMapTests,
+ findBestKey_onlyOneRequiredDown_matchTwoRequiredChangesItem);
+ FRIEND_TEST(KeyMapTests, findBestKey_noRequiredDown_cannotMatch);
++#endif
+
+ private:
+ //! Ways to synthesize a key
diff --git a/x11-misc/synergy/files/synergy-1.9.1-internal-gmock-gtest.patch b/x11-misc/synergy/files/synergy-1.9.1-internal-gmock-gtest.patch
new file mode 100644
index 000000000000..bc8a96130575
--- /dev/null
+++ b/x11-misc/synergy/files/synergy-1.9.1-internal-gmock-gtest.patch
@@ -0,0 +1,23 @@
+--- a/src/test/CMakeLists.txt
++++ b/src/test/CMakeLists.txt
+@@ -14,20 +14,5 @@
+ # You should have received a copy of the GNU General Public License
+ # along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+-include_directories(
+- ../../ext/gtest
+- ../../ext/gtest/include
+- ../../ext/gmock
+- ../../ext/gmock/include)
+-
+-add_library(gtest STATIC ../../ext/gtest/src/gtest-all.cc)
+-add_library(gmock STATIC ../../ext/gmock/src/gmock-all.cc)
+-
+-if (UNIX)
+- # ignore warnings in gtest and gmock
+- set_target_properties(gtest PROPERTIES COMPILE_FLAGS "-w")
+- set_target_properties(gmock PROPERTIES COMPILE_FLAGS "-w")
+-endif()
+-
+ add_subdirectory(integtests)
+ add_subdirectory(unittests)
diff --git a/x11-misc/synergy/files/synergy-1.9.1-pthread.patch b/x11-misc/synergy/files/synergy-1.9.1-pthread.patch
new file mode 100644
index 000000000000..46ae6e1588b8
--- /dev/null
+++ b/x11-misc/synergy/files/synergy-1.9.1-pthread.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -141,6 +141,8 @@
+ check_library_exists ("pthread" pthread_create "" HAVE_PTHREAD)
+ if (HAVE_PTHREAD)
+ list (APPEND libs pthread)
++ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pthread")
++ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pthread")
+ else()
+ message (FATAL_ERROR "Missing library: pthread")
+ endif()
diff --git a/x11-misc/synergy/files/synergy-1.9.1-qt-5.11.patch b/x11-misc/synergy/files/synergy-1.9.1-qt-5.11.patch
new file mode 100644
index 000000000000..7a706a084d0b
--- /dev/null
+++ b/x11-misc/synergy/files/synergy-1.9.1-qt-5.11.patch
@@ -0,0 +1,31 @@
+--- a/src/gui/CMakeLists.txt 2018-05-11 23:30:26.425509147 +0200
++++ b/src/gui/CMakeLists.txt 2018-05-11 23:31:53.237354182 +0200
+@@ -39,7 +39,7 @@
+ target_link_libraries (synergy dns_sd)
+ endif()
+
+-qt5_use_modules (synergy Core Widgets Network)
++target_link_libraries (synergy Qt5::Core Qt5::Widgets Qt5::Network)
+ target_compile_definitions (synergy PRIVATE -DSYNERGY_VERSION_STAGE="${SYNERGY_VERSION_STAGE}")
+ target_compile_definitions (synergy PRIVATE -DSYNERGY_REVISION="${SYNERGY_REVISION}")
+
+--- a/src/gui/src/ActionDialog.cpp 2018-04-10 12:18:42.000000000 +0200
++++ b/src/gui/src/ActionDialog.cpp 2018-05-11 23:33:50.814498692 +0200
+@@ -25,6 +25,7 @@
+
+ #include <QtCore>
+ #include <QtGui>
++#include <QButtonGroup>
+
+ ActionDialog::ActionDialog(QWidget* parent, ServerConfig& config, Hotkey& hotkey, Action& action) :
+ QDialog(parent, Qt::WindowTitleHint | Qt::WindowSystemMenuHint),
+--- a/src/gui/src/ScreenSetupView.cpp 2018-04-10 12:18:42.000000000 +0200
++++ b/src/gui/src/ScreenSetupView.cpp 2018-05-11 23:35:33.304496343 +0200
+@@ -22,6 +22,7 @@
+
+ #include <QtCore>
+ #include <QtGui>
++#include <QHeaderView>
+
+ ScreenSetupView::ScreenSetupView(QWidget* parent) :
+ QTableView(parent)