summaryrefslogtreecommitdiff
path: root/x11-misc/sunflower/sunflower-0.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-05 23:52:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-05 23:52:45 +0000
commit1c33e521c460dc40899ce7bc919602b842ce27e2 (patch)
tree580eefad4cce1e883e7504b93352a9029b53036d /x11-misc/sunflower/sunflower-0.5-r2.ebuild
parent65e4244e411c4f65f55f2aa91f39e228f4c0680b (diff)
gentoo auto-resync : 05:03:2023 - 23:52:45
Diffstat (limited to 'x11-misc/sunflower/sunflower-0.5-r2.ebuild')
-rw-r--r--x11-misc/sunflower/sunflower-0.5-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-misc/sunflower/sunflower-0.5-r2.ebuild b/x11-misc/sunflower/sunflower-0.5-r2.ebuild
new file mode 100644
index 000000000000..e1ad6bd9575d
--- /dev/null
+++ b/x11-misc/sunflower/sunflower-0.5-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_USE_PEP517="setuptools"
+inherit distutils-r1 xdg
+
+MY_PN="Sunflower"
+MY_PV="${PV}-63"
+
+DESCRIPTION="Small and highly customizable twin-panel file manager with plugin-support"
+HOMEPAGE="https://github.com/MeanEYE/Sunflower
+ https://sunflower-fm.org/"
+SRC_URI="https://github.com/MeanEYE/${MY_PN}/archive/refs/tags/${MY_PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
+
+RDEPEND="${DEPEND}
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ x11-libs/vte
+"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+src_prepare() {
+ default
+
+ # Upstream's get_version requires a lot of BDEPENDS we do not want.
+ sed 's%version=get_version()%version="0.5"%g' -i setup.py
+}