summaryrefslogtreecommitdiff
path: root/x11-misc/spnavcfg/spnavcfg-1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /x11-misc/spnavcfg/spnavcfg-1.0.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'x11-misc/spnavcfg/spnavcfg-1.0.ebuild')
-rw-r--r--x11-misc/spnavcfg/spnavcfg-1.0.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/x11-misc/spnavcfg/spnavcfg-1.0.ebuild b/x11-misc/spnavcfg/spnavcfg-1.0.ebuild
index f2b2fbed5906..d49c3125f96a 100644
--- a/x11-misc/spnavcfg/spnavcfg-1.0.ebuild
+++ b/x11-misc/spnavcfg/spnavcfg-1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit toolchain-funcs
+inherit toolchain-funcs qmake-utils
DESCRIPTION="GTK-based GUI to configure a space navigator device"
HOMEPAGE="http://spacenav.sourceforge.net/"
@@ -29,5 +29,11 @@ src_configure() {
}
src_compile() {
- emake CC="$(tc-getCC)"
+ local args=(
+ CC="$(tc-getCC)"
+ MOC="$(qt5_get_bindir)/moc"
+ RCC="$(qt5_get_bindir)/rcc"
+ UIC="$(qt5_get_bindir)/uic"
+ )
+ emake "${args[@]}"
}