summaryrefslogtreecommitdiff
path: root/x11-misc/spnavcfg/spnavcfg-0.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /x11-misc/spnavcfg/spnavcfg-0.3.1.ebuild
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'x11-misc/spnavcfg/spnavcfg-0.3.1.ebuild')
-rw-r--r--x11-misc/spnavcfg/spnavcfg-0.3.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-misc/spnavcfg/spnavcfg-0.3.1.ebuild b/x11-misc/spnavcfg/spnavcfg-0.3.1.ebuild
new file mode 100644
index 000000000000..3f3ca2c51ac4
--- /dev/null
+++ b/x11-misc/spnavcfg/spnavcfg-0.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="GTK-based GUI to configure a space navigator device"
+HOMEPAGE="http://spacenav.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/spacenav/spacenavd%20config%20gui/${PN}%20${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="x11-libs/gtk+:2"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ app-misc/spacenavd[X]"
+
+src_configure() {
+ econf --disable-debug --disable-opt
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}