summaryrefslogtreecommitdiff
path: root/x11-misc/slop/slop-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-01 20:42:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-01 20:42:22 +0000
commit721254b86a09bdedd5eefd0de7899c90ea2ead1a (patch)
tree895fca7b3bd570d8df743dd518a6f36deca1a241 /x11-misc/slop/slop-9999.ebuild
parent618c3037024b4e5328531cdc07c6ceb7486f5329 (diff)
gentoo resync : 01.01.2018
Diffstat (limited to 'x11-misc/slop/slop-9999.ebuild')
-rw-r--r--x11-misc/slop/slop-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-misc/slop/slop-9999.ebuild b/x11-misc/slop/slop-9999.ebuild
new file mode 100644
index 000000000000..4aef7f894258
--- /dev/null
+++ b/x11-misc/slop/slop-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="An application that queries the user for a selection for printing"
+HOMEPAGE="https://github.com/naelstrof/slop"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/naelstrof/slop.git"
+else
+ SRC_URI="https://github.com/naelstrof/slop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="opengl"
+
+RDEPEND="
+ dev-libs/icu:=
+ x11-libs/libX11
+ x11-libs/libXext
+ opengl? (
+ media-libs/glew:0=
+ virtual/opengl
+ x11-libs/libXrender:=
+ )"
+DEPEND="
+ ${RDEPEND}
+ media-libs/glm"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSLOP_OPENGL=$(usex opengl)
+ )
+ cmake-utils_src_configure
+}