summaryrefslogtreecommitdiff
path: root/x11-misc/slop/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-31 22:30:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-31 22:30:36 +0000
commit618c3037024b4e5328531cdc07c6ceb7486f5329 (patch)
tree7c9f8d50c6f5fbd53f3df583c471f5d2e5c34202 /x11-misc/slop/files
parent76dfef0cec9170000357d2f354e412daf48941fc (diff)
gentoo resync : 31.12.2017 (final resync this year)
Diffstat (limited to 'x11-misc/slop/files')
-rw-r--r--x11-misc/slop/files/slop-4.3.21-no-cppcheck.patch20
-rw-r--r--x11-misc/slop/files/slop-4.3.21-no-gengetopt.patch33
-rw-r--r--x11-misc/slop/files/slop-4.3.21-no-librt.patch37
-rw-r--r--x11-misc/slop/files/slop-4.3.21-no-opengl.patch39
-rw-r--r--x11-misc/slop/files/slop-6.3.46-fix-build-system.patch56
5 files changed, 56 insertions, 129 deletions
diff --git a/x11-misc/slop/files/slop-4.3.21-no-cppcheck.patch b/x11-misc/slop/files/slop-4.3.21-no-cppcheck.patch
deleted file mode 100644
index f92c57f977df..000000000000
--- a/x11-misc/slop/files/slop-4.3.21-no-cppcheck.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 361f930..0982647 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -33,15 +33,6 @@ else()
- message( FATAL_ERROR "Your operating system isn't supported yet! CMake will now exit." )
- endif()
-
--# Add a check target for our makefile.
--find_program( CPPCHECK_EXECUTABLE cppcheck
-- DOC "A tool for static C/C++ code analysis." )
--if (CPPCHECK_EXECUTABLE)
-- add_custom_target( "check"
-- COMMAND "${CPPCHECK_EXECUTABLE}" "--enable=all" "*"
-- WORKING_DIRECTORY src VERBATIM )
--endif()
--
- # Here we generate some of our code if we can. I package it pre-generated
- # so nobody has to go find and install gengetopt if they don't want to.
- find_program( GENGETOPT_EXECUTABLE gengetopt
diff --git a/x11-misc/slop/files/slop-4.3.21-no-gengetopt.patch b/x11-misc/slop/files/slop-4.3.21-no-gengetopt.patch
deleted file mode 100644
index 13f79eef2110..000000000000
--- a/x11-misc/slop/files/slop-4.3.21-no-gengetopt.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -33,29 +33,6 @@ else()
- message( FATAL_ERROR "Your operating system isn't supported yet! CMake will now exit." )
- endif()
-
--# Here we generate some of our code if we can. I package it pre-generated
--# so nobody has to go find and install gengetopt if they don't want to.
--find_program( GENGETOPT_EXECUTABLE gengetopt
-- DOC "A tool to generate code to grab command line options." )
--find_program( SED_EXECUTABLE sed )
--if ( GENGETOPT_EXECUTABLE AND SED_EXECUTABLE )
-- message( "-- Regenerating cmdline.in" )
-- # gengetopt generates cmdline.h, then we move it to cmdline.in.
-- execute_process( COMMAND "${GENGETOPT_EXECUTABLE}" "--input=options.ggo"
-- WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/src" )
-- file( RENAME "${CMAKE_CURRENT_SOURCE_DIR}/src/cmdline.h" "${CMAKE_CURRENT_SOURCE_DIR}/src/cmdline.in" )
-- # Due to a bug in gengetopt, we have to manually insert some code.
-- # Replace the first instance of REPLACEME with some text.
-- # Eight backslashes = two in the code because of how many instances of escaping is happening.
-- execute_process( COMMAND "${SED_EXECUTABLE}" "-i" "0,/REPLACEME/{s/REPLACEME/X=%x\\\\\\\\nY=%y\\\\\\\\nW=%w\\\\\\\\nH=%h\\\\\\\\nG=%g\\\\\\\\nID=%i\\\\\\\\nCancel=%c\\\\\\\\n/}" "cmdline.c"
-- WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/src" )
-- # Then replace remaining instances.
-- execute_process( COMMAND "${SED_EXECUTABLE}" "-i" "s/REPLACEME/X=%x\\\\nY=%y\\\\nW=%w\\\\nH=%h\\\\nG=%g\\\\nID=%i\\\\nCancel=%c\\\\n/" "cmdline.c"
-- WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/src" )
--else()
-- message( "Warning: Command gengetopt or sed not found! Won't regenerate command line code. (If you're just compiling this doesn't matter.)" )
--endif()
--
- # By default our src/options.ggo has our cmake versions variables for
- # the 'version ""' line. We replace them here.
- # The ${CMAKE_SOURCE_DIR} is there to fix problems with OpenBSD's out-of-source build black magic.
diff --git a/x11-misc/slop/files/slop-4.3.21-no-librt.patch b/x11-misc/slop/files/slop-4.3.21-no-librt.patch
deleted file mode 100644
index 0b95b833ffda..000000000000
--- a/x11-misc/slop/files/slop-4.3.21-no-librt.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -75,10 +75,6 @@ find_package( GLX REQUIRED )
- find_package( XRender REQUIRED )
- find_package( XRandr REQUIRED )
- find_package( GLEW REQUIRED )
--# This library is needed only for Ubuntu it seems, some platforms don't even
--# ship with it. I couldn't find a way to do a test compile to check if librt
--# was needed, so instead I just didn't mark it as REQUIRED.
--find_package( RT )
-
- set( CMAKE_CXX_FLAGS
- "${CMAKE_CXX_FLAGS} ${CMAKE_IMLIB2_CXX_FLAGS}" )
-@@ -96,10 +92,6 @@ include_directories( "${IMLIB2_INCLUDE_DIR}"
- ${XRENDER_INCLUDE_DIRS} )
- endif()
-
--if ( RT_INCLUDE_DIR )
-- include_directories( ${RT_INCLUDE_DIR} )
--endif()
--
- # Executable
- add_executable( "${BIN_TARGET}" ${source} )
-
-@@ -119,11 +111,6 @@ if ( CMAKE_OPENGL_SUPPORT )
- endif()
-
-
--if ( RT_LIBRARY )
-- target_link_libraries( "${BIN_TARGET}"
-- "${RT_LIBRARY}" )
--endif()
--
- install( TARGETS ${BIN_TARGET}
- DESTINATION "${CMAKE_INSTALL_PREFIX}/bin" )
-
diff --git a/x11-misc/slop/files/slop-4.3.21-no-opengl.patch b/x11-misc/slop/files/slop-4.3.21-no-opengl.patch
deleted file mode 100644
index 2f596b65e992..000000000000
--- a/x11-misc/slop/files/slop-4.3.21-no-opengl.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 62cc1a6..f5d66e5 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -71,14 +71,8 @@ endif()
-
- # Obtain library paths and make sure they exist.
- set( CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmakemodules" )
--find_package( Imlib2 REQUIRED )
- find_package( X11 REQUIRED )
- find_package( XExt REQUIRED )
--find_package( OpenGL REQUIRED )
--find_package( GLX REQUIRED )
--find_package( XRender REQUIRED )
--find_package( XRandr REQUIRED )
--find_package( GLEW REQUIRED )
-
- set( CMAKE_CXX_FLAGS
- "${CMAKE_CXX_FLAGS} ${CMAKE_IMLIB2_CXX_FLAGS}" )
-diff --git a/src/x.hpp b/src/x.hpp
-index 2478414..f35e722 100644
---- a/src/x.hpp
-+++ b/src/x.hpp
-@@ -26,7 +26,6 @@
- #include <X11/Xlib.h>
- #include <X11/cursorfont.h>
- #include <X11/extensions/shape.h>
--#include <X11/extensions/Xrandr.h>
-
- #include <stdlib.h>
- #include <cstring>
-@@ -97,7 +96,6 @@ public:
- std::vector<bool> m_mouse;
- bool mouseDown( unsigned int button );
- bool m_keypressed;
-- XRRScreenResources* m_res;
- private:
- slop::CursorType m_currentCursor;
- bool m_good;
diff --git a/x11-misc/slop/files/slop-6.3.46-fix-build-system.patch b/x11-misc/slop/files/slop-6.3.46-fix-build-system.patch
new file mode 100644
index 000000000000..2ca92f9d2ac8
--- /dev/null
+++ b/x11-misc/slop/files/slop-6.3.46-fix-build-system.patch
@@ -0,0 +1,56 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,16 +1,13 @@
+ cmake_minimum_required(VERSION 3.1.3)
+
++include(GNUInstallDirs)
++
+ set(CMAKE_BUILD_TYPE Debug CACHE STRING "Choose the type of build (Debug or Release)")
+-if ( NOT CMAKE_INSTALL_PREFIX )
+- set(CMAKE_INSTALL_PREFIX "/usr")
+-endif()
+
+-project(slop)
++project(slop VERSION 6.3.46 LANGUAGES CXX)
+
+ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY "${CMAKE_SOURCE_DIR}/bin/")
+
+-set( CMAKE_INSTALL_MANDIR "${CMAKE_INSTALL_PREFIX}/share/man" CACHE PATH "Directory where man pages reside. (/usr/share/man, /usr/local/share/man, etc.)" )
+-
+ set( CMAKE_COMPRESS_MAN TRUE CACHE BOOL "Whether or not to compress the man pages for install." )
+
+ if ( CMAKE_COMPRESS_MAN )
+@@ -21,7 +18,7 @@
+
+ include_directories("${PROJECT_BINARY_DIR}")
+
+-add_definitions(-DSLOP_VERSION="v6.3.46")
++add_definitions(-DSLOP_VERSION="v${PROJECT_VERSION}")
+
+ # The names have to be unique unfortunately.
+ set(EXECUTABLE_NAME "slop")
+@@ -43,11 +40,13 @@
+
+ set_property(TARGET ${LIBRARY_NAME} PROPERTY CXX_STANDARD_REQUIRED ON)
+ set_property(TARGET ${LIBRARY_NAME} PROPERTY CXX_STANDARD 11)
++set_property(TARGET ${LIBRARY_NAME} PROPERTY CXX_EXTENSIONS OFF)
+
+ add_executable(${EXECUTABLE_NAME} src/main.cpp)
+
+ set_property(TARGET ${EXECUTABLE_NAME} PROPERTY CXX_STANDARD_REQUIRED ON)
+ set_property(TARGET ${EXECUTABLE_NAME} PROPERTY CXX_STANDARD 11)
++set_property(TARGET ${EXECUTABLE_NAME} PROPERTY CXX_EXTENSIONS OFF)
+
+ set( CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/modules" )
+
+@@ -83,7 +82,7 @@
+ target_link_libraries(${EXECUTABLE_NAME} ${ICU_UC_LIBRARIES} )
+ endif()
+
+-install( TARGETS ${EXECUTABLE_NAME} DESTINATION "${CMAKE_INSTALL_PREFIX}/bin" )
+-install( TARGETS ${LIBRARY_NAME} DESTINATION "${CMAKE_INSTALL_PREFIX}/lib" )
+-install( FILES ${CMAKE_SOURCE_DIR}/src/slop.hpp DESTINATION "${CMAKE_INSTALL_PREFIX}/include" COMPONENT development )
++install( TARGETS ${EXECUTABLE_NAME} DESTINATION "${CMAKE_INSTALL_BINDIR}" )
++install( TARGETS ${LIBRARY_NAME} DESTINATION "${CMAKE_INSTALL_LIBDIR}" )
++install( FILES ${CMAKE_SOURCE_DIR}/src/slop.hpp DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}" COMPONENT development )
+ install( FILES "${CMAKE_SOURCE_DIR}/${MANTARGET}" DESTINATION "${CMAKE_INSTALL_MANDIR}/man1" COMPONENT doc )