summaryrefslogtreecommitdiff
path: root/x11-misc/skippy/skippy-0.5.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 19:43:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 19:43:32 +0100
commitfa1962ff69701bd9c0f15fb225cdbfb487125e0e (patch)
tree85b35bd5a3c73ea562768237a25da176adef5744 /x11-misc/skippy/skippy-0.5.0-r2.ebuild
parentbd8ca999980e9c0c9ae40a11789c858bb58769e3 (diff)
gentoo auto-resync : 15:07:2022 - 19:43:32
Diffstat (limited to 'x11-misc/skippy/skippy-0.5.0-r2.ebuild')
-rw-r--r--x11-misc/skippy/skippy-0.5.0-r2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-misc/skippy/skippy-0.5.0-r2.ebuild b/x11-misc/skippy/skippy-0.5.0-r2.ebuild
new file mode 100644
index 000000000000..51f0174ed446
--- /dev/null
+++ b/x11-misc/skippy/skippy-0.5.0-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A full-screen task-switcher providing Apple Expose-like functionality"
+HOMEPAGE="http://thegraveyard.org/skippy.php"
+SRC_URI="http://thegraveyard.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="media-libs/imlib2[X]
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXinerama
+ x11-libs/libXmu
+ x11-libs/libXft"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-pointer-size.patch
+ "${FILESDIR}"/${P}-Makefile.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-imlib2-pkg-config.patch
+)
+
+DOCS=( CHANGELOG skippyrc-default )
+
+src_compile() {
+ tc-export CC PKG_CONFIG
+
+ default
+}
+
+pkg_postinst() {
+ elog
+ elog "You should copy skippyrc-default from /usr/share/doc/${PF} to"
+ elog "~/.skippyrc and edit the keysym used to invoke skippy."
+ elog "Use x11-apps/xev to find out the keysym."
+ elog
+}