summaryrefslogtreecommitdiff
path: root/x11-misc/shutterbug/shutterbug-1.7.49.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/shutterbug/shutterbug-1.7.49.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/shutterbug/shutterbug-1.7.49.ebuild')
-rw-r--r--x11-misc/shutterbug/shutterbug-1.7.49.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-misc/shutterbug/shutterbug-1.7.49.ebuild b/x11-misc/shutterbug/shutterbug-1.7.49.ebuild
new file mode 100644
index 000000000000..97de0d1eef96
--- /dev/null
+++ b/x11-misc/shutterbug/shutterbug-1.7.49.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit fox
+
+DESCRIPTION="Screenshot utility based on the FOX Toolkit"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~hppa ppc ~ppc64 ~sparc x86"
+IUSE="+jpeg +png +tiff"
+
+DEPEND="
+ x11-libs/fox:1.7
+ x11-libs/libICE
+ x11-libs/libSM
+ jpeg? ( virtual/jpeg )
+ png? ( media-libs/libpng:0 )
+ tiff? ( media-libs/tiff:0 )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ FOXCONF="$(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable tiff)" fox_src_configure
+}