summaryrefslogtreecommitdiff
path: root/x11-misc/seetxt/seetxt-0.72-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/seetxt/seetxt-0.72-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/seetxt/seetxt-0.72-r1.ebuild')
-rw-r--r--x11-misc/seetxt/seetxt-0.72-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-misc/seetxt/seetxt-0.72-r1.ebuild b/x11-misc/seetxt/seetxt-0.72-r1.ebuild
new file mode 100644
index 000000000000..a61c7e234474
--- /dev/null
+++ b/x11-misc/seetxt/seetxt-0.72-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Clever, lightweight GUI text file and manual page viewer for X windows"
+HOMEPAGE="https://code.google.com/p/seetxt/ http://seetxt.sourceforge.net/"
+SRC_URI="https://seetxt.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${PV}-0001-fix-linking.patch" \
+ "${FILESDIR}/${PV}-0002-fix-shared-files-install.patch"
+ eautoreconf
+}
+
+src_install() {
+ dodir /usr/share/man/man1
+ default
+ sed -i -e 's|local/||' "${D}/usr/share/seetxt-runtime/filelist" || die "sed failed"
+}