summaryrefslogtreecommitdiff
path: root/x11-misc/safeeyes/safeeyes-2.1.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-06 06:10:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-06 06:10:37 +0000
commit19a808581ca18addf4b12d09f7e440b7244679e5 (patch)
tree437f8a4d37be714e61ef02a9ee68f0616e860826 /x11-misc/safeeyes/safeeyes-2.1.5.ebuild
parentb256b4b120d8269d4415eac0c354eb603a7bf953 (diff)
gentoo auto-resync : 06:01:2023 - 06:10:36
Diffstat (limited to 'x11-misc/safeeyes/safeeyes-2.1.5.ebuild')
-rw-r--r--x11-misc/safeeyes/safeeyes-2.1.5.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/safeeyes/safeeyes-2.1.5.ebuild b/x11-misc/safeeyes/safeeyes-2.1.5.ebuild
new file mode 100644
index 000000000000..b865ffc84d69
--- /dev/null
+++ b/x11-misc/safeeyes/safeeyes-2.1.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="tk" # for site-packages/Xlib/ext/randr.py
+DISTUTILS_USE_PEP517=setuptools
+
+inherit xdg distutils-r1
+
+DESCRIPTION="Linux alternative to EyeLeo"
+HOMEPAGE="https://github.com/slgobinath/SafeEyes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libappindicator:3[introspection]
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/croniter[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-sound/alsa-utils
+ x11-apps/xprop
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-misc/xprintidle
+ "
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}